Menu
Reply
  • 33
  • 0
  • 1
tonewheelkev
Tuning in
276 Views
Message 1 of 6
Flag for a moderator

Horrendous connection probs after 'upgrade' to 4G....HELP!!!

'Upgraded' to 4G back in October....and connection problems right from the start!

When calls can be made....3G is always defaulted to....can't say I've managed to complete any calls in last 5 months using 4G.

As far as I can understand...phone is capable of 4G...and newtork can be selected in settings.

Appalling connections....have actually deteriorated, and now it takes many attempts to successfully dial a number.

Have appealed to customer service using 789 (even that number took many attempts) and advised how I might re-register phone on Virgin network. Tried this several times....makes no difference.

Also....attempted to use the text help facility (07533016422)....this proved to be no more than a total and absolute joke......a waste of time!!! I should add that....before going to 4G....the phone (Elephone P9000) worked at 100%

0 Kudos
Reply
  • 3.05K
  • 397
  • 764
Superuser
Superuser
273 Views
Message 2 of 6
Flag for a moderator

Re: Horrendous connection probs after 'upgrade' to 4G....HELP!!!

Are you saying the phone does not fall back to 3G to make a call? 

4G is data only on Virgin and many other MNVO's

0 Kudos
Reply
  • 33
  • 0
  • 1
tonewheelkev
Tuning in
265 Views
Message 3 of 6
Flag for a moderator

Re: Horrendous connection probs after 'upgrade' to 4G....HELP!!!

...what I'm saying is...that I can rarely make calls. Perhaps I'm confusing matters....but since 'move' to 4G...and change to my sim package.....I can't make calls at all conistently. Phone says its dialling....but nothing happens. Sometimes see 'Radio Off'....or No Network (or the like).....retrying several/many times.....eventually gets me through.
0 Kudos
Reply
  • 72
  • 4
  • 6
Forum Team
Forum Team
237 Views
Message 4 of 6
Flag for a moderator

Re: Horrendous connection probs after 'upgrade' to 4G....HELP!!!

Hi tonewheelkev.

 

Thanks for reaching out. Sorry to see that you're having mobile service issues since you upgraded to 4G. I appreciate that you've tried to reach us about this but sadly, issue still occurs. I can see that you've tried to do a manual network search several times but it makes no difference.

 

We'd like to take a closer look over this and do what's necessary. We can do this via online chat.

 

Let us know how you get on.

 

Rule_C

0 Kudos
Reply
  • 33
  • 0
  • 1
tonewheelkev
Tuning in
194 Views
Message 5 of 6
Flag for a moderator

Re: Horrendous connection probs after 'upgrade' to 4G....HELP!!!

Dialling problems persist. Just took 8 attempts to call another mobile number. Phone says "No Radio" (or perhaps "Radio Off") My Phone says "Dialling"....but line remains dead, and call is then cut/reset. Have tried re-registering on network....doesn't help. The Phone is : Elephone P9000.....and this worked perectly before upgrading to 4G back in October 2018 Need to sort this now!! Thanks
0 Kudos
Reply
  • 2.05K
  • 225
  • 371
paulchambers061
Problem sorter
182 Views
Message 6 of 6
Flag for a moderator

Re: Horrendous connection probs after 'upgrade' to 4G....HELP!!!

The "radio" you refer to is also known as the modem, or baseband. That is used for lots of things, including calls, wifi, gps, etc.

It certainly looks in your case to be the root of your problem.

Are you on the latest software version for the phone ?

It could need a factory reset to fix, or latest software. If you go that route, make sure you back up important stuff (like contacts, which can be saved to google).

0 Kudos
Reply