Showing results for 
Search instead for 
Did you mean: 

Data roaming not working (iPhone13 Denmark)

Joining in

Before I left uk I had roaming enabled and had international barring removed.

on landing in Denmark I didn’t receive the typical local network text.

I’ve tried rebooting phone; toggling off/on mobile data and airplane mode; I’ve checked APN settings which appear to be in order (although marginally different to those offered in virgin help page).

Any ideas what else I can try please?


Forum Team
Forum Team

Hi Martini77 👋,

Welcome to the Community Forums! Thank you for your post.

If your device receiving any sort of mobile network signal at all, or do you have no service?

Have you tried manually selecting the network on your handset?

Also, have you ensured that roaming was switched on on our end, and in your device settings? 



Hi Beth, 

Thanks for your reply.

I have no signal at all.

I have turned off auto network select and manually selected different networks but it is always the same - no service/signal what do ever.

Yes, roaming is switched on at virgin end and device end.

That’s why I’m so confused it isn’t working.

Any of their idea, please?

Hi Martini77,

Thanks for coming back to us.

It might just be that you don't have any service at all in the area that you're in. I'm afraid we would be unable to check the coverage outside of the UK.

Have you been to different areas at all whilst being in Denmark?

Thank you


I'm in the centre of Copenhagen, so the general coverage is definitely not the issue.

Any ideas?


Very Insightful Person
Very Insightful Person

It's an iPhone. Good bet your SIM has not automatically switched to International mode.

You may or may not have a SIM Toolkit where you can do that manually. (Virgin seem to be removing this in prep for the move to O2, but screwing up roaming in the process,)

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Thanks Enli - I've removed sim and replaced and now it's working. 👍

That's a great to hear @Martini77 and a big thank you to Enli for their help in resolving this. 


If you need any help in the future please do pop back to us and we will do all we can to help.