Showing results for 
Search instead for 
Did you mean: 

Data not working

Joining in

Ok, this is getting annoying now. At the start of August, I said I was going to leave Virgin, because I was having issues with coverage and I could get more data on a plan somewhere else. I was offered a new contract, which gave me 10x the data, for the same price if I stayed. So I did. I was also told services had just been upgraded in my area.

Since then, I've found out I can get 5G. In the cross roads of my street and another, and that's the only place. Otherwise its 4g everywhere. But matter if I'm on 3 4 or 5g, data does not work. I've checked all the settings 4 times over, and I can't get data to work. Annoyingly I get the arrows to show its working, and my account shows I am using data, but I'm not. Worse of all, it effects my messages on WhatsApp, I'm a carer and use WhatsApp to stay in touch if I'm out somewhere and the person needs to get in touch with me... but now I get no message. Then I get home, phone connects to WiFi and I get bombarded with 20 messages sent whilst I was out 

I have a video doorbell attached too, so I can speak to any delivery drivers should I not be available to take their parcels in. This worked brilliantly prior to the upgrades in my area, now I can't connect unless I'm on the WiFi.

Really useless, and really annoying.


Forum Team
Forum Team

Hi psychoduck,

Thanks for your post and welcome back to the community.

Apologies for the service issues faced, can I ask regarding this matter even when you're around your local area are you unable to retrieve 5G? Also whereabouts are you located?



Located in Newcastle under Lyme, 5g I can get in my local town, but not around the village I live in apart from the one Cross roads. But no matter where, I cant fetch data

5bar signal, both arrows lighting up like its busy, and I can't even refresh a webpage

Ahh okay, thanks for getting back to me. 

Also to clarify is the 4G service poor/not working whilst this is happening?

Secondly what phone model do you have?

Let us know,


4g service is the same, says I have a signal but data just won't transfer. Struggle to get messages delivered via anything that requires data usage.

If I'm out of the house, I basically need to go all the way back to 2g in my settings in order to get a reliable stable signal that will download the tiny bit of data needed for a WhatsApp message, but it's no use for anything that requires picture, video, or a whole Web search.


Phone is a Samsung Galaxy A32. 

Very Insightful Person
Very Insightful Person

What APN settings do you have?

Worth Double checking against these

The merged settings work fine with Samsung 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Thanks for the additional information psychoduck, please double check the settings and APN information from enlli's post to ensure these match what you have on your phone. There is also the option to text ALL to 789922 where a message will be sent with the correct settings but it's best to check first as if these are correct then the cause will be something else.



Checked the settings, everything is the same as mentioned in the post.

I'll be in the home all day today, so will check data coverage when I leave tomorrow. Pointless to switch from WiFi to data in the house, as the signal is low in my house and I rarely get above a 2g signal here anyway, so would not be able to tell if the data wasn't working, or if the signal was just too low to retrieve data.

Thanks psychoduck, let us know once you have had chance to check this away from your home. If you have another handset you could try the SIM in also this would help with diagnostics.




 ok, tried the settings which were exactly the same, and also tried the mixed settings. This screen shot is all I get. 4g signal, both arrows, no movement.


It's really annoying, because I don't even get texts most of the time, so can't be sure if I'm not missing calls too.


Tried the sim in my wife's Moto G50, same thing. Which I expected, because my wife has a virgin phone and experiences similar issues. The only difference being she can't get 5g, and her data does transfer, just very slowly. But definitely way slower than before we got told our area had been upgraded. Signal has always been a bit hit and miss, but in areas with signal 4g speeds were great and video doorbell connection was perfect for what I need. But the upgrade has completely killed the reliability.

If I go into other cities, I occasionally get reliable data transfer, most of the time it's slow but never completely fails like this.

The upgrade has completely destroyed the purpose of the phone, and now makes me unreliable as a carer because I can't be reached whenever I'm not around and I can't make sure to always handle parcel deliveries via the video doorbell.