Showing results for 
Search instead for 
Did you mean: 

Can't hear international calls

Tuning in

Any solution here? I have had this problem ever since joining Virgin Mobile over 4 years ago! Still no fix, and doesn't look there is much help on how to resolve this. Can I have some help on this as after this trip, I will be leaving Virgin Mobile for this reason as its not good enough!


Forum Team (Retired)
Forum Team (Retired)

Hi tobias2191, 

Welcome to the Community and thank you for posting. 

I am sorry to hear you are experiencing issues with international calls. 

Can you please confirm if you are currently abroad and if roaming has been activated?

Thanks , 



On our wavelength

I have just been back to England and collected the new Sim card Virgin sent to me.  Now I am back in Italy and initial tests seem to show that has solved the problem.  Perhaps 'older' Sim cards from Virgin don't work properly abroad?  I was on Three and had no problems when in Italy.

Forum Team
Forum Team

Hi there @muirgm, thanks for the update. I'm glad to see that this new sim seems to have resolved the issue for you. 

If you do have any other questions regarding using your phone abroad, you can check our roaming hub here.

Please do let us know if you continue to see any further issues, we will be happy to help.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

Yes I am abroad but roaming is on 

Hi @tobias2191,

Thanks for coming back to us with an update. Have you rebooted your device since being abroad? Did you receive a text message to confirm that your Roaming has been activated in the country you're in?

Can you please confirm the device you have?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ


Thanks for replying. Yes I have rebooted and also did receive the text when I landed.

This has happened for years, not just on this trip.


Hi @tobias2191,

Thanks for your update on this, can you please try to do the following:


1. Select Apps from the Home Screen

2. Select Virgin SIM Toolkit Icon

3. Select Roaming > Mode > Manual

4. Select International

Select Settings from the Home Screen

Select Phone (if on iOS 14 or above, select Mobile Data)

Select SIM Applications

Select Roaming > Mode > Manual

Select International

Once you've done this, please reboot your device. When you return to the UK, please follow the same settings, but instead of selecting Mode > Manual, click Mode > Automatic.


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

I loose all signal when I do that. I am in the Isle of Man and always have trouble here

Hi @tobias2191,

Thanks for checking. I'm going to drop you a private message, so I can gather some additional details. Please look out for it in the top-right of the Forums, in the purple envelope.


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ