Menu
Reply
Highlighted
  • 1
  • 0
  • 0
Joining in
167 Views
Message 1 of 2
Flag for a moderator

Anyone else having problem with connecting to Virgin Media WIFI on the underground with Three?

I have to go into 'wifi' on my phone, click Virgin Media Wifi, wait for the ad page to load, 'skip ad' at every single station. Has been happening for months and it's driving me mad. Three admitted there was an issue a few months ago, just wondered if anyone else on Three is having the same problem? Oh, and I have cleared my safari history/cache multiple times and it hasn't helped.
0 Kudos
Reply
Highlighted
  • 2.65K
  • 155
  • 328
Forum Team
Forum Team
25 Views
Message 2 of 2
Flag for a moderator

Re: Anyone else having problem with connecting to Virgin Media WIFI on the underground with Three?

Hi there @owlietenil2

 

Welcome to the VirginMedia Community forum and thank you so much for your first post here; we are sorry to understand that as a Three customer, you are having some issues connecting to the WiFi on the London Underground. 

 

This service is indeed free to customers with EE, Virgin Media, Three, Vodafone and O2. Once you have activated, you should auto connect on each platform.  

 

If you are having issues once registered, you would need to chat with your own provider for further assistance. You can check for more information on the WiFi and find the best way to get home for your network on the London Underground website below

 

London Underground WiFi

 

Hope that helps - Cheers

Katie - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply