Menu
Reply
NicholaF
  • 2
  • 0
  • 0
Joining in
535 Views
Message 1 of 3
Flag for a moderator

TiVo box issue

My box was making a funny sound this morning. I’ve gone to switch on this afternoon but all I am getting is starting up and welcome screen. I’ve tried all of the reboot solutions I’ve seen on the page but nothing is working. Any further help? Or do I need a new box? 😞 

Tags (3)
0 Kudos
Reply
newapollo
  • 7.93K
  • 1.16K
  • 2.16K
Very Insightful Person
Very Insightful Person
524 Views
Message 2 of 3
Flag for a moderator

Re: TiVo box issue

Hi NicholaF,

Have you tried disconnecting the box from the mains for 10 minutes ?

It does sound like you need a new box though, in which case you need to contact the Faults team on 150 from a Virgin landline, or 0345 454 1111, options 1,1 and 2 (Faultsbut best to call at 8am to avoid call queues 

When calling Faults you will get an automated response asking you to press 1 for the link to online support, ignore the options and don't press any buttons then you should be placed into a queue and an agent should pick up the phone and resolve the problem.

You could also try the text messaging service. Just send  a text with a description of TV Faults to 07533 051809. Your message will go into a queue and a representative will respond to you as soon as possible. It may take a few days. 

 

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali



I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Problem Solved? Click to mark as a Helpful Answer or use Kudos to say thanks for a useful post


0 Kudos
Reply
NicholaF
  • 2
  • 0
  • 0
Joining in
518 Views
Message 3 of 3
Flag for a moderator

Re: TiVo box issue

Thank you for your reply, I think it’s the box also! I’ve tried everything In the hope it’s not the box because it’s the only way we can watch tv! I’ve never had a good signal from just the aerial 

I have managed to call through but have been on hold for 25mins already 😩

the help messages online didn’t solve either 

0 Kudos
Reply