Menu
Reply
  • 8
  • 0
  • 0
arthurjy
Joining in
252 Views
Message 1 of 2
Flag for a moderator

Slow apps on TIVO, YouTube stuttering

Got an old Cisco 500GB TIVO box, have put up with these issues for a while, but I'd like to see if there really is any solutions, or it's just a bit crap and that's that.

First up: App loading time - so slow. Netflix, iPlayer, YouTube, all take 2-3 minutes to load up and become usable. If I try to watch something after a search that takes me to iPlayer, I can go make a cup of tea and drink it before anything actually starts playing...

YouTube: lots of stuttering/buffering. Broadband is fine, 50-60Mbps reported on speed tests. Playing 1080p@60fps YouTube vids on PlayStation3 (over ethernet) or MacBook (over wifi) play perfectly smooth, at the exact same times the TIVO box fails to play them smoothly.

On plus side, Netflix and iPlayer do generally playback smoothly, once they do finally load.

Dunno, if my TIVO box is getting a bit elderly now. I did see I was eligible for a 1TB TIVO box for £0.00 extra which I tried to order thinking it was worth trying a newer box, except some nice customer service person cancelled the order I they thought we already had a box...

So what's the deal here? Is this just how it is, or am I putting up with this crap needlessly?

0 Kudos
Reply
  • 9.49K
  • 541
  • 1.16K
jb66
Alessandro Volta
248 Views
Message 2 of 2
Flag for a moderator

Re: Slow apps on TIVO, YouTube stuttering

Sounds like a normal Tivo, you would be better getting the faster v6
0 Kudos
Reply