Menu
Reply
MikeH2020
  • 2
  • 0
  • 0
Joining in
789 Views
Message 1 of 4
Flag for a moderator

Engineer required please!

Tivo box is not working correctly it keeps losing signal half was through a Netflix programme or on demand........ It is hard wired with a cat6 ether net cable which works fine on all other devices. I have phoned and was passed from pillar to post and finally told I would have to pay nearly £150 to upgrade to a V6 box, no thank! ( this is what I thought I had because my other box is a v6). Also spent neat a week on a virtual chat and still no difference....... End of my tether to be honest if not sorted soon I will be changing provider! 

0 Kudos
Reply
Anonymous
Not applicable
783 Views
Message 2 of 4
Flag for a moderator

Re: Engineer required please!

The Tivo doesn't use your internet it has its own modem
MikeH2020
  • 2
  • 0
  • 0
Joining in
664 Views
Message 3 of 4
Flag for a moderator

Re: Engineer required please!

Thanks Apcyberax, funny no one at virgin media has told me that! That aside do you have any idea why it keeps losing signal? 

Tags (1)
0 Kudos
Reply
Tom_F
  • 3.03K
  • 177
  • 367
Forum Team
Forum Team
650 Views
Message 4 of 4
Flag for a moderator

Re: Engineer required please!

Hi MikeH2020, thanks for getting in touch.

 

Sorry to hear about the problems you've been having with your Tivo Box.

 

I'd like to take a look from here and see what we can do to help. I'll send a PM shortly to confirm a few details (the purple envelope) and hope to hear back from you soon.

 

Tom

 

0 Kudos
Reply