Menu
Reply
proxymc
  • 2
  • 0
  • 0
Joining in
728 Views
Message 1 of 6
Flag for a moderator

Studio Speakers via Audio Analog Converter to TiVo

Hello,

I was trying to hook up my active studio speakers with TiVo via optic cable and decent Digital to Analog Audio Converter. This setup works perfectly fine for Playstation 4 but when I am trying to switch it to the tv box I am getting only a white/clicking noise. My only guess is that TV box accepts only digital signal. Is that true?

0 Kudos
Reply
LittleMick73
  • 4.94K
  • 513
  • 840
Superstar
707 Views
Message 2 of 6
Flag for a moderator

Re: Studio Speakers via Audio Analog Converter to TiVo

Yes
0 Kudos
Reply
Roger_Gooner
  • 6.54K
  • 473
  • 1.14K
Legend
683 Views
Message 3 of 6
Flag for a moderator

Re: Studio Speakers via Audio Analog Converter to TiVo

When you say "switch" do you mean a TOSLINK switch?

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
proxymc
  • 2
  • 0
  • 0
Joining in
641 Views
Message 4 of 6
Flag for a moderator

Re: Studio Speakers via Audio Analog Converter to TiVo

Yes. Well, my converter has 4 toslink outputs and I can switch between them via remote control. However, this is irrelevant because I tried plugging only Tv Box and I am getting only a noise. I believe it has to be a digital signal, which is a bit bizarre, as Playstation 4 works only with analogue.

0 Kudos
Reply
Roger_Gooner
  • 6.54K
  • 473
  • 1.14K
Legend
630 Views
Message 5 of 6
Flag for a moderator

Re: Studio Speakers via Audio Analog Converter to TiVo

Any converter can fail. I suggest you look at upgrade options for audio delivered over HDMI such as a soundbar or speakers driven by an AVR.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
Anonymous
Not applicable
627 Views
Message 6 of 6
Flag for a moderator

Re: Studio Speakers via Audio Analog Converter to TiVo

Have you checked the optical output settings?

It may need setting to PCM.

0 Kudos
Reply