Menu
Reply
Highlighted
  • 8
  • 0
  • 0
Joining in
829 Views
Message 1 of 5
Flag for a moderator

Hub 3 - PC auto connecting to 2.4ghz, won't connect to 5ghz - Not fast enough!

Hi!

Just installed the Hub 3 upgrade from Superhub 2. My PC now automatically connects to Hub 3 on the 2.4 band. If I switch the 2.4 band off on the Connect app, the PC won't connect to the internet.

Is there a way to force my PC to stick to the 5ghz connection? If not, I will need to arrange switching to another router. 

Thanks/. 

0 Kudos
Reply
Highlighted
  • 4.66K
  • 856
  • 1.24K
Very Insightful Person
Very Insightful Person
825 Views
Message 2 of 5
Flag for a moderator

Re: Hub 3 - PC auto connecting to 2.4ghz, won't connect to 5ghz - Not fast enough!

Hello

What wireless card is in your PC ?

Regards Mike

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Highlighted
  • 3.5K
  • 566
  • 1.38K
Very Insightful Person
Very Insightful Person
824 Views
Message 3 of 5
Flag for a moderator

Re: Hub 3 - PC auto connecting to 2.4ghz, won't connect to 5ghz - Not fast enough!

Does your PC support 5GHz connections?  If it doesn't have a 5 GHz capable wireless that could explain things.  Many cheaper laptops have 2.4 GHz only adaptors, as are many add on wireless cards for desktops (or in the case of my daughter's one year old Dell desktop, it has wifi built in, but only supports 2.4 GHz).

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Highlighted
  • 8
  • 0
  • 0
Joining in
801 Views
Message 4 of 5
Flag for a moderator

Re: Hub 3 - PC auto connecting to 2.4ghz, won't connect to 5ghz - Not fast enough!

It does have a 5ghz wireless card in the PC so that's not the issue. I have now gone into the settings on the Hub and separated the two bands. Still quite slow though. 

0 Kudos
Reply
Highlighted
  • 89
  • 2
  • 2
Dialled in
743 Views
Message 5 of 5
Flag for a moderator

Re: Hub 3 - PC auto connecting to 2.4ghz, won't connect to 5ghz - Not fast enough!

Have you separated your 2.4ghz and 5ghz channels and also have you tried changing the 5ghz channel as when it is on auto it might be on a channel witch is  incompatible with your WiFi card, suggest starting off on channel 36 and work your way up on channels to see if your pc picks up the 5ghz 

My Broadband Ping - 500Mbps
0 Kudos
Reply