Showing results for 
Search instead for 
Did you mean: 

Can’t connect robot vacuum

Joining in

I’ve tried everything! Can’t connect my vacuum. It worked on my last router with sky. 

I also have another Wi-Fi thermometer and that also wouldn’t connect. 

Anybody else have this problem of even better a solution?


Dialled in

I use my virgin hub as a modem, and my wifi/router is a Netgear, but I spent an hours trying to get my robo vac connected. After trying various permutations, and using it without wifi for the day, (on mine just pressed power on a second time momentarily), it was amazing. Next day, tried the Wifi connection again and it worked first time, and has been rock solid since. I followed the instructions on mine given to the letter. Hope you can get yours working, my wife and I both love it more than the dog!

Alessandro Volta

Generic devices, such as a robot vacuum and a thermometer, often only have wi-fi capabilities on 2.4 GHz.

VM's hubs, by default, use the same network SSID name for 2.4 GHz and 5 GHz. This sometimes causes problems for those devices.

Things you can try might include ...

Temporarily turn off the 5 GHz wi-fi on the VM hub. See if you can connect your devices then, once connected, turn the 5 GHz wi-fi back on again.

Alternatively, a variation on the same idea is to give each SSID a separate name e.g. VM####_2 and VM####_5

To change these settings you have to turn of 'Smart' wifi / 'Wifi Optimisation' IIRC

If you are using VM's pods, I think you have to keep a shared SSID name and the 'Smart' wifi otherwise the pods don't work. So if you are using VM's pods the above suggestions won't work for you.