Showing results for 
Search instead for 
Did you mean: 

cant login TVgo app and computer

Tuning in

Let see if I ll have more luck than 100 of unhappy customers about this.

Cant login in ios (latest version), android, pc and mac. error 'oops, blablabla'







yes, i can login to myvirgin account

yes, im the main holder of the account

yes, i changed my password

yes, i re install the app on phones

and yes to anything else you may ask, I ve tried it all

yes, i know it is not the mods fault's, the support team's fault. however, you represent virgin, and i cant go to Richard to tell him what i think about a poorly backend designed app.

Yes, you should check my account backend, and check if the box tvgo is ticked

Yes, you can pm me to verify my account

Yes, you can delete then recreate my account to get this sorted, although

and finally, yes, this is absolutely ridiculous. a company like Virgin should have dev their app properly




since has been happening since I joined Virgin back in May.



Forum Team
Forum Team

Hi @Bio_Logik


Thank you for your post and welcome to our community.


I am sorry to hear about the issues you are having with TV GO.


I appreciate you've said you have tried all options to resolve, however could you please confirm if you have tried clearing your cache and cookies?


Could you also please confirm if you have tried different browsers?


Please pop back to us when you can.



Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide


yes and yes, different computer, and even different networks



Hi Bio_Logik,

Thank you for reaching back out and for advising what you have tried so far, have you tried deleting the App on all devices and then re-installing it, are you able to sign into other apps and your Online Account?



yes, tried all of that

i can log fine on myvirgin account

Thanks for the reply @Bio_Logik on the forums.

I will look in to this for you and assist on the issue with TV Go
Watch out for the purple envelope inviting you in.

Kind regards.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I am having this exact issue for months. I've tried troubleshooting using everything above but I am still getting the exact same error as the OP.

What can I do?

hope that they fix an issue which has been happening for years it seems

Thanks for the response on the forums page @Bio_Logik.

We will investigate this matter and try to resolve this best as posible.

Kind regards.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Any update, Ilyas?

Thank you