Showing results for 
Search instead for 
Did you mean: 

can not play tv on go on my tablet shows not available {license error code.License.invalid

Joining in



Forum Team
Forum Team

Hi @tonihen 

Welcome to the community forums

Sorry to hear you're having issues with the TV GO app on your tablet. 

Is it just the tablet that you cannot access the TVGO app on? 

Do you have a VPN enabled at all? What region do you have your device register to in your device settings?


Here to help 🙂
Virgin Media Forums Agent

Just put tvgo on iphone 6 and working fine.The tablet is nexus 7, there's no VPN connection cannot see any region in tablet settings.


Forum Team (Retired)
Forum Team (Retired)

Thanks for the response tonihen,

Just to clear a few things off, have you tried to re-install the App?

Also has the tablet been able to gain access prior?

Let us know,


Tried re installing,just the same.It did initially work on tablet long time ago.

Hi @tonihen,

Are you able to try and access and use the TV Go service via a browser instead of the app? Let us know if that's any better or if the issue remains.


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!