Showing results for 
Search instead for 
Did you mean: 

Virgin TV go stopped working

Joining in

A few weeks ago my Virgin TV Go app stopped allowing to stream any content either Live TV or Box set. The app itself works but when I try to stream Live TV, I get an error message saying Not Available Sorry - we can’t play this at the moment.

could this be due to my last upgrade to IOS 15.5 on my iPad?

any other ideas please?


Forum Team (Retired)
Forum Team (Retired)

Hi @BBUser2014,

Welcome to our Community Forums! Thank you for your first post and I'm sorry to hear that you're having some issues with your TVGo App! We understand that this is not ideal.

Is the app and Live Streaming working from any other device? Is it just the iPad that is showing you that error? 

Have you been able to take a look at our TVGo Help page to see if this can help with your issue?

Have you tried to delete the app from your iPad and then tried to re-install it?

Let us know how you get on and if you need any further help or assistance.

Thank you.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Thank you for getting back to me. I have tried reinstalling the app on my iPad several times but still getting the same error message. Today I installed the app on my iPhone and it worked fine.

So only the iPad seems to be an issue.

Thanks for coming back to us @BBUser2014, can you please advise me if the iPad requires any further updates?

What model of iPad are you using to try and watch Live content via the TV Go application?

Do other streaming apps have any issues that are similar?

Kindest regards,


Hello. Good news, I have updated my iPad to the latest IOS version and it has resolved the issue.

 Thank you for your help and advice.

Glad to hear the issue has been resolved @BBUser2014.

Please do not hesitate to contact us if you need any further help 🙂


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs