Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go not recognising registered device

Joining in

Hi, my Virgin TV Go app suddenly stopped working on my primary laptop.  Says I have exceeded device level.  I can see the device in the DEVICE MANAGEMENT tab.  Please help.

thanks, Mark


Forum Team
Forum Team

Hi @MarkSullivan 👋 Thank you for your post 😀

We're sorry to hear about the problem you're experiencing 😔

Given the device is listed, have you tried removing it and re-adding it? If so, has that made any difference?

General advice on how to use the Virgin TV Go app and website can be found here


Hi Daniel,

I can see a device list and I can clearly see my laptop on that list (I gave it a distinctive name).  However, the message on the screen says I can make no further changes until 1st June.  

I just need Virgin to recognise that the device is on the list !!

Thanks, Mark


Hi @MarkSullivan 👋

I can get the devices  reset for you. 

Will pop you a PM 📩 now to help further.

Hope to hear from you soon!

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Joining in

I have the same problem. My laptop running windows 10 is on the list of devices but I keep getting the message that I have exceeded device level. I have tried numerous suggestions on this forum to try and resolve this including re-registering the laptop but now I am locked out until November!

Hi Keith,

Thank you for reaching out, when you are using TG G on the laptop, is this Via a Browser, if so do you have it set to delete Cookies and Cache, the reason I ask this, each time to restart the PC/Laptop everything is cleared and the App see it as a new device, to stop this please untick automatically clear Cache and Cookies.



Hi Paul,

Thank you for your reply. Unfortunately Cache and Cookies are not set to 'Clear'. I tried uninstalling and reinstalling TV Go app but still not working. Just get the message "You have reached the maximum of devices...register a new device on 01-11-2023". This is now the 3rd month I have been getting this message and not being able to use the app! I have tried phoning Virgin Media tech support but  after spending hours on the phone I still no resolution to this problem. Getting to the stage where I am considering cancelling my subscription.



Joining in

Any help would be very much appreciated