Menu
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
81 Views
Message 1 of 1
Flag for a moderator

Virgin TV Go Web Sign In Failing

Per multiple other complaints about Virgin TV Go sign in failing. Similar issue.

Windows 10 64bit 19041.388;

Chrome (latest build), using primary account details, which work to log in to My Virgin Media, give Sign-in Failed errors.  Try registering, it recognises both my primary email address and mobile number and shows the alternative registered accounts, but not primary one and can't select any of the others!

Firefox (latest build), exactly the same fault except it keeps flashing up security errors about a Flash plug-in!

Tried using Edge (latest build), logged in straight away!!!

Asked family member to try, using another Windows 10 64bit computer, but using Edge (latest build) and Chrome (latest build), and same faulty error message. Wouldn't log them in.

Installed the Windows 10 desktop App (found a hidden link to do so when I clicked on Chrome's 3-dots (was heading for Chrome's settings when I spotted the "Install TV Go App" link hidden there).  Installed App on Windows but same unable to sign in error messages!

Installed the App on Samsung Galaxy S8+, opened it and it logged in straight away!!!

Tried creating a separate virginmedia.com sub-account under the main account. Once created it gives a message stating that account will be able to access TV Go if the main account has authorised it.  Have hunted high and low in the main account and the sub-accounts to try and find how to authorise that sub-account... nothing, nada, zilch! It's not possible from what I can see.

Also, can log in to My Virgin Media and then go to https://www.virginmedia.com/shop/tvgo-tvcontrol or https://virgintvgo.virginmedia.com/en.html in the same or new tabs, and I'm no longer signed in and have to sign in all over again (obviously on https://virgintvgo.virginmedia.com/en.html it's messed up and doesn't allow signing back in to the same account on that page).

I've now wasted over 3 hours of my life trying to get this to work!

GREAT!!! Some part of this question must've done the trick, within 5 minutes of posting this, after hours of trying, Chrome on this Windows 10 computer has just allowed the sign in to work here https://virgintvgo.virginmedia.com/en.html AND on the desktop App!!!

0 Kudos
Reply