Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go App

Tuning in

Hi, I have tried to use the TV Go App on my Android phone, I have the Virgin 360 box, however when I try and view a recording on the app i receive an error message saying, "Only available at home, this recording is only available on your home network."

I am on my home network as I am on my home Wi-Fi, does anyone know of this issue and how to resolve it? 






Forum Team
Forum Team

Hi Davva,

A warm welcome and thanks for posting on our community forums. We're sorry to hear that you're unable to watch our TVGO service due to this error message and you are on your home network.

Can we ask When you go into the diagnostics screen, are you seeing any error which states CPE IP Unknown?

If this happens and you're adamant that you're indeed on the same broadband network as your TV box, please follow the below diagnostics/troubleshooting checks.. 

1.) Is your TV box is on.

2.) If it isn't, check that what Standby mode the box is in – it needs to be in Active Start or Fast Start. 

3.) When put into Fast Start, you should be able to see recordings immediately when you use the App.

4.) When put into Active Start, you will need to wait a few minutes. The App will send a message to wake up the box over the network.

5.) You need to ensure your NOT  using a VPN – which can be triggered by your anti-virus software. There should be a setting on your anti-virus that ensures it recognises the home router as 'safe'. 

6.) Are you using a 'Mesh' network? 

       a.) Mesh networks can run on one two modes. If the Mesh is in Bridged mode – sometimes called "Access Point" – then the box can be plugged into the Virgin Media router directly, and all will work ok. 

       b.) If it's not in Bridged mode – often called "Router" – then the box needs to be plugged into the Mesh NOT the Virgin Media router, or it will not work. 

       c.) "Router" mode is often the default for Mesh systems, so it's important to check. 

7.) Wi-Fi extenders/repeaters may also have a similar set up, so could cause a problem. Our Wi-Fi Pods should be fine though. 

Once you have performed the above checks/diagnostics this should resolve the issue, if this does not and your still experiencing the same error, please come back to us for further assistance. 

Kind regards Jodi. 

Hi Jodi,

Thanks for your reply.

I have gone through your checklist and still have the same problem:

  • I am able to see the recordings in the app but unable to watch them. The error is "Only available at home. This recording is only available on your home network. If you are at home, check that you are connected to the same network or SSID as your Virgin TV box." 
  • I am at home and on the same SSID as the box and the same frequency 5Ghz.
  • I can see and view live TV, and the TV Guide

Any help advice would be appreciated - I called Virgin Media and TBH they didn't have an answer.

Thank you for coming back to us Davva!

Sorry to hear that the fixes offered have not helped just yet. 

Would you be able to confirm if you have tried deleting the TV GO app off the device and re-installing it?

If not, if you can please try this and let us know how you get on!

Thank you. All the best!



Hi Molly,

I tried uninstalling and reinstalling the app, still no change. I can play to the TV from the app and see the recordings listed but cannot play on my phone I get the error message as previously listed?

Hi @Davva,

Thanks for the update on this. To confirm, are you downloading the recordings to your device, whilst connected to your Home network? In addition, is this on all recordings, or just some? Are you able to name a few, so we can check this further?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Hi I can see the recordings on the app listed the problem is trying to watch them on my phone e.g. Would I lie to you? S14 Ep1 when I press the play on the app I receive the error message as previously described. Another recording that gives the same error is Red a film recorded on the 14 Oct.

Kind regards






Thanks for coming back to us Davva, have you tried to download the recordings to your device?