Showing results for 
Search instead for 
Did you mean: 

Virgin TV Control App

Joining in

I have this app on my iPad Air.  I've used it without problems for years, being able to view recorded programmes using it.  However in the past few days it thinks I'm trying to watch programmes away from the home box and I can't access anything I've recorded.  Can anyone help please?


Forum Team
Forum Team

Hi Nicolay1970, 

Thanks for your post and welcome to the forums. It's great having you on board with us in the Community. 

I'm sorry to hear that you've been unable to watch your recordings recently. Is your box connected to the network through an ethernet cable or through WiFi?

Do you get the same issue when trying to watch On Demand content or Live TV too or is this only happening when watching recordings? 

Do you get the issue error across other devices too or is this only on the iPad Air?

Pop back and let us know. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

It’s connected through WiFi and it’s only with my iPad Air which has never previously been a problem. I can watch TV Go on my iPad still but I can’t watch recorded programmes through the TV Control app. Both apps work on other devices perfectly well.

Thanks for coming back to us Nicolay1970,

Can we ask if you are able to forget your network and reconnect?

If this does not work, can we ask if you are using a VPN? We would also recommend turning off your gps or location services on your iPad Air.

Please try the above and come back to us if you still require further assistance.

Kind regards Jodi. 

I’ve just tried forgetting the network and reconnected. Not using a VPN. Location switched off. Still not working.

I’ve discovered the average network speed is 0.0 Mbps!! 

Hi Nicolay1970, sorry to hear that the above steps have not worked. 

Can you elaborate what you mean and where you have seen your network speed is 0.0Mbps? Are you devices able to connect to the internet fine and it's just your iPad Air?

Can you make sure that all other devices you use to watch your recordings are not connected to the app in the background or have the app open on other devices at all. 

Here to help 🙂
Virgin Media Forums Agent

I tested the broadband through the Virgin media app and that’s where that information is from.  Through the same app on my iPhone it says 2.3mbps. My iPad connects to the internet perfectly well, it just can’t seem to locate the TiVo box. 

Can you please try fully rebooting both your hub and set top box for me. You can only watch your recorded shows via your own home network. They will not be able to play if you are connected to a mobile data or other private network than your own. 

Once rebooted - can you please see if you are able to view your recordings on the iPad Air from your Virgin Media home network. 

Please unsure the app and iPad is fully updated with the latest software and you have no other devices running the TV control app

Here to help 🙂
Virgin Media Forums Agent