Showing results for 
Search instead for 
Did you mean: 

Unable to stream virgin tv go on PC

Joining in

As the title says I am unable to stream live TV through any browser or the TV go app on windows. My PC is completely up to date.

I have tried changing my password and no success as some other users have had.

sometimes it will play for half a second before a message pops up saying unable to play at this time. No error codes present.


Forum Team
Forum Team

Hi Ringogringo 


Thank you for your post and welcome to our community.


I am sorry to hear about the issues you are having with the TV GO service.


The app is available to all Virgin TV customers at no extra cost and is compatible with Android, iOS, Windows 10 and PC/Mac.


Is the PC a registered device on your TV GO account?


Please pop back to us when you can. 




Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide


the PC is a registered device, I have not had this problem before. I have tried different browsers and they all have the same issue.

I am having a similar problem, I can hear audio and either get a blank screen or still pictures, no video. Same on PC as Amazon Fire.

Forum Team (Retired)
Forum Team (Retired)

Thank you Ringoringo. 

Can you please try downloading the app on the PC and letting us know if you still have the same problem?



Hi Natalie,

same issue on the app as I am having on all browsers.





Thanks Ringogringo, 

I am sorry if you're still having this issue on our TV GO App. 

Are you able to log in to your Online Account with no issues? These two go hand in hand so if there is an issue on your online account, this would have an affect on the app too. 

I have a really helpful link here 👉 TV GO App issues - Which covers most problems with the app, please take a look and see if it helps resolve the issue. 



Hi Megan,

Thanks for the link. My issue isn’t really covered on there.

I can log into the app/website with no issues until I try to stream any channel on my PC.

Works fine on my iPhone.

Forum Team (Retired)
Forum Team (Retired)

Thanks for the responses there, 

Can I ask have you tried to re-register the device at all?

Let us know,



I have tried this multiple times with no success. It will sometimes ask me to register the device even though it is already registered. It also asks me to register the same device on different browsers which doesn’t seem right.