Showing results for 
Search instead for 
Did you mean: 

TV go app on chrome book

Joining in

Hello. Everytime I watch TV go on my Chromebook it says I have max device registered and need to remove one. It is the same chrome book and I can see it on the list (actually 3 times). I have read few posts on forum about this. I'm not incognito browsing etc. I have also tried downloading the app on chrome book. 


Very Insightful Person
Very Insightful Person

Hi @Mcgivern-72 

Do you clear your browser cookies?

To use Virgin TV Go in a browser please ensure you’ve got cookies enabled in your browser, that is listed as a trusted site, your browser is set to allow protected content, and you allow pop ups from the Virgin TV Go website.

Note: If you register a computer using a browser, you’ll need to use the same browser with Virgin TV Go. Using a different browser, clearing cookies or using incognito mode will be seen as a different device.


I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Forum Team
Forum Team

Hi Mcgivern-72, 

Thanks for your post and welcome to the Community. It's really great having you on board with us. 

We're sorry to hear you're having an issue with your device not recognising a device you've already previously registered. 

As mentioned above, it could be down to the browser cookies. 

Have you been able to re-register the device to use it? If not, let us know and we can reset things from this end for you. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hello. It's still not working

Thanks for the response there Mcgivern072,

Has this issue happened on any other devices also? 

Also have you been able to replace any registered devices when signing in?

Let us know,


Joining in

I have spent the last couple of hours going round in circles trying to reset/delete some devices linked to my sky account. Had the same problem about not being able to login to the Skygo option even though I could log in to MyVirgin Media however….

I have I have stumbled upon an option that has worked for me and have actually deleted some obsolete devices. The link I selected was: 

Hope this helps some of you out there.

Hi thanks for the reply. 

I can't do anymore changes for another 3 weeks. It works fine on my phone, never an issue. I had my Chromebook registered in the other 4 slots. It's doing my nut in


Hi @Mcgivern-72

Thanks for coming back to the thread.

I shall send you a PM now to reset the devices


Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

HI John,


Thanks for getting back to me. That would be great. I work away from home 5 days a week so having to watch my programmes on my phone is not great

Hi Mcgivern-72

Thanks for joining me on PM. Just to update the thread, the TV Go devices were reset.

If you need further assistance, please pop back and we can assist further.


Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill