Showing results for 
Search instead for 
Did you mean: 

TV Go app

Joining in

I have perpetual problems trying to get the TV Go app to connect to the TV Box so that I can watch my recordings on an iPad. Every evening I have to try; restart the TV box, restart the iPad, restart the app multiple times. Often have to restart my wi-fi and have tried swapping from my own wi-fi to Virgin Media wi-fi on Hub 3.0 and this makes no difference. I have removed and reinstalled the app more than once and on more than one iPad - I regularly use 2 iPads, both are running the most recent IOS and both behave the same.

Both iPads connect easily early in the day and only with difficulty in the evening, every evening.

When the iPads don't connect the Diagnostics value CPE IP is "unknown" although the TV Box is switched on, running and connected by ethernet to the network. The diagnostics on the TV box show everything is running as it should do.

Please advise how I can make this app connect consistently.





Hi Megan_L

I tried the suggested fix this evening on one of the iPads. Connected to my TV Box, could watch live TV but not recordings.

The CPE IP remains "Unknown".

I disconnected and reconnected to the TV Box, shutdown and restarted the TV GO app several times but am unable to get a connection with a CPE IP address.



Hi I am having the exact same issue for some time now ever since i upgraded to 360, mine also says CPE IP address unknown very frustrating beginning to wish I had never upgraded. The temp fix never worked for me either, regards Ian

Hi blackie1964,

We are sorry to see you are still facing this issue and the work around didn't help, we are working to resolve this ASAP.



"We are sorry to see you are still facing this issue and the work around didn't help, we are working to resolve this ASAP."



Is there a timescale for the resolution, please?

Without the TV Go app Virgin TV is all but useless and if there isn't a resolution soon then I'll have to ask for a refund for a service which isn't being delivered.

Like others, we wish we hadn't upgraded because the previous version was all but flawless.



Hi Ian, thanks for getting back in touch on this thread! Sorry to hear that the issues with TV Go app on the Ipad's is still present. 

Would you be able to let us know if you have issues when trying to watch all content via the TV GO app or if it is happening for some specific channels or pay per view services? 

Do you currently have split Wi-Fi networks? (Separate named networks for 2.4ghz and 5ghz Wi-Fi channels) If so, there may be a possibility this is contributing to the issues. You may want to check your advanced hub settings - you can do this here 👉 How to set up Virgin Media broadband, and try managing which network your device is on, or try re-enabling channel optimisation so your devices can move freely between the two networks. If you need any help and support in doing this please let us know and we can send you a PM to offer some help also. 
Otherwise, please come back and update us once you have looked into this so we know if you believe this to be the root cause of the issues with your TV go working on your devices. 

Thanks for your continued patience with this! I appreciate it has been ongoing a while for you - hopefully we can get to the bottom of this, and resolve things. 

All the best!


Hi Molly,

Thank you for responding to my post.

I am unable to watch recordings (which is my main interest) and when I check the diagnostics on the device the CPE ID displays "unknown". 

Around a month ago I confirmed this CPE ID value which confirms, according to Megan_L, I am  "part of a wider field of customers having the same issue"

I don't have split wi-fi networks and the problem remains whether I use the Virgin Hub or my preferred mesh wi-fi. 

On 21 November I was asked, as follows -

Thanks for coming back to us about this frustrating issue with the TV GO app, we have received some information from our IT team about this which may help you. 

We firstly need to find out whether you are part of a wider field of customers having the same issue, if you could locate your CPE IP address on the app by following this flow - 

Click on your profile icon at the top in the app > Settings > Diagnostics > CPE IP.  

If this is "Unknown" then it means you are part of the wider issue, so please let us know if this is the case.

I subsequently confirmed the CPE IP value of "unknown" which means I am part of the wider issue and it is a resolution to the "wider issue" I am chasing.


Hi @IWC24,

Thanks for coming back to us. 

It is an issue we are aware of and working on a fix Ian. I will chase for an update and get back to you asap. 

Thanks for your continued patience. 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Thank you @Ayisha_B



Is there any progress towards a resolution for the TV GO app problems, please?



Hi @IWC24,

Thank you for your reply, I am sorry you have not had an update on this. I will chase this up for you.