Showing results for 
Search instead for 
Did you mean: 

TV Go app

Joining in

I have perpetual problems trying to get the TV Go app to connect to the TV Box so that I can watch my recordings on an iPad. Every evening I have to try; restart the TV box, restart the iPad, restart the app multiple times. Often have to restart my wi-fi and have tried swapping from my own wi-fi to Virgin Media wi-fi on Hub 3.0 and this makes no difference. I have removed and reinstalled the app more than once and on more than one iPad - I regularly use 2 iPads, both are running the most recent IOS and both behave the same.

Both iPads connect easily early in the day and only with difficulty in the evening, every evening.

When the iPads don't connect the Diagnostics value CPE IP is "unknown" although the TV Box is switched on, running and connected by ethernet to the network. The diagnostics on the TV box show everything is running as it should do.

Please advise how I can make this app connect consistently.





Accepted Solutions

Very Insightful Person
Very Insightful Person

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

See where this Helpful Answer was posted


Joining in
Last night (16 November) was fairly typical - two iPads connect without difficulty in the later afternoon. One is used and remains connected until around nine thirty when it disconnects in the middle of playing a recording. From then on neither iPad will connect. This morning around eight o'clock both connect without any difficulty.

This is beginning to look like a capacity problem.

Hi there @IWC24, welcome to our forum and thanks for your post.

I'm sorry to see that you are having issues with watching recordings on the TV GO App. What box are you attempting to connect the App to?

Do you have the app enabled in the iPad's local network privacy settings? Also are you using the devices on the most recent update? I would also recommend checking to see if the app is due any update.

Just to check also, are you using any VPN's with your internet or 3rd party equipment?

Let us know and we will be happy to assist further.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

Hi Nathan,

Thanks for replying to my questions about the problems I am having with the TV GO app. 

I am trying to connect to an ARRIS-DCX960-MPA+ running Application 76_2022092, build 4.43

The TV Go app is enabled in the iPads' networks settings (they both connect sometimes), both are running iPasOS 16.1 and the TV Go app is running Build 4.34.4 ( which is, I believe, the most recent. The app has been reinstalled on both devices within the last week or so.

I am not using a VPN and while my preference is to use a Tenda Mesh Wi-Fi I have tried the Wi-Fi on the Virgin Hub 3 but using Virgin Wi-Fi doesn't improve the app's ability to connect.



Thanks for coming back to us IWC24,

Can we ask if your able to use an alternative device to try and connect. Do you have any Android devices you could use? As you have tried all other options, have no VPN and no 3rd party equipment attached, this would be out next suggestion to see if it connects.

Kind regards Jodi. 

Hi Jodi,

Thanks for responding.

I don't have any Android devices but I experience connection problems on two different iPads. Essentially, either they both connect or neither connects.

Kind regards



Forum Team (Retired)
Forum Team (Retired)

Thanks for the responses,

Also just to clarify, is there no other devices that the recordings can be viewed without issue as well?



Hi Kain,

Thanks for responding.

I have one other iPad and a couple of phones. I have tried them occasionally but to try to keep things manageable I have been concentrating on just two devices. It is only recordings that are a problem - even when I can't what recordings I can watch live TV so I guess that connects in a different way.



Hi IWC24,

Thanks for coming back to us about this frustrating issue with the TV GO app, we have received some information from our IT team about this which may help you. 

We firstly need to find out whether you are part of a wider field of customers having the same issue, if you could locate your CPE IP address on the app by following this flow - 

Click on your profile icon at the top in the app > Settings > Diagnostics > CPE IP.  

If this is "Unknown" then it means you are part of the wider issue, so please let us know if this is the case.

I do have a work around for the time being through thanks to a Super User on the forums that has found a temporary fix. If you could click the icon next to the search bar in the top right corner and disconnect from your 360 box and reconnect. You may need to do this again if the issue reoccurs next time until the IT team conclude their investigate with a fix. 

Please let us know about your CPE IP, whether it's Unknown and also whether the temporary fix works for you.



Hi Megan_L

Thank you for responding.

When my devices are unable to connect the CPE IP is shown as "Unknown".

I'll try your suggested fix the next time we have the problem and let you know what happens.