Menu
Reply
TvTone
  • 5
  • 0
  • 0
Joining in
353 Views
Message 1 of 1
Flag for a moderator

Sky sports app “Could not play channel”

I have had sky sports for over a year and not had any difficulty in watching the premium channels on iPad or iPhone until about 4 weeks ago. Now when I try to watch through the sky sports app I get a padlock on the graphic screen and a message reading “ Could not play channel. Your subscription does not allow you to watch this programme”

I note from previous posts that this is a fairly common problem. I have tried all suggested remedies without success. ie delete and reinstall apps (sky sports and virgin go), reboot hub and 360 box. Both phone and tablet appear on the devices page of the tv go app, but not on the sky app.

I have spoken to 5 or more people at Virgin, All tried to be helpful, but did not have any answers but have confirmed that I am paying for both sky and bt sports channels including HD. (All channels are ok through the tv box.)

Both phone and iPad are running iOS 14.1.

Any ideas please?

0 Kudos
Reply