Showing results for 
Search instead for 
Did you mean: 

Sky Sports - There was an unexpected error

Tuning in

I haven't been able to log in to Sky Sports via Virgin media login page for months in Google Chrome. From the sky sports page, I click log in > Virgin Media UK sign in, and then I'm brought to a page that says "There was an unexpected error" (addr: This page is useless with no meaningful troubleshooting steps.

I can stream on my phone through the app ok, and on other browsers (including incognito chrome), but not normal Chrome. My devices lists (vm and sky) are not full, and I have used this device successfully before and haven't removed it from my list at any point.

I have tried rebooting, clearing cache/cookies for sky/virgin sites, reinstalling chrome (it is up to date v105.0.5195.127), but nothing works. Others seem to have had a similar problem and for some the fix just happened out of the blue, but none have worked for me.

If I paste the address for the login page, obtained from a working browser, into Chrome, it resolves to the same wholesale error page. Seems like the browser/device combo has been blacklisted or blocked, though there are no concrete error messages in the logs.


Forum Team (Retired)
Forum Team (Retired)

Hi mh15, 

Welcome to the Community and thank you for posting. 

I am very sorry to hear you are experiencing issues accessing Sky Sports when using Chrome. 

Can you please confirm that you are attempting to login and view the channels from here?




Very Insightful Person
Very Insightful Person

Hi @mh15 

That error code is usually due to having a screenshot tool open, or in some cases  messenger, chat windows, teams, zoom (practically anything that can screenshot a page or view video)

When I kept getting that error I uninstalled the Sky Desktop Player (version 6.0.1) and then reinstalled the Desktop Player. For some reason the page said it was downloading version 6.0.0 but  it actually downloaded 6.0.1 again and all started working again.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Hi Natalie_L,

I can confirm that is the page I am trying to log in from.

Hi newapollo,

I think my problems are further upstream than the desktop player. The player itself works fine, if launched from a browser other than Chrome. The problem is on the sky sports login page, which is before I'd even get the option to download the desktop player or launch it. I tried reinstalling the player anyway, but it had no effect. I closed all running programs and checked that nothing funny was running in the background, but still no dice.

Forum Team (Retired)
Forum Team (Retired)

Thank you for your reply and confirming it is the Sky Sports page that is having the issue. 

If the problem is specifically with the Sky Sports page on Chrome, this could potentially be an issue that needs to be raised with Sky but we would want to do what we can to help. 

Just to confirm, are you having any issues using Chrome for TV Go? 




Hi Nat,

No issues with Virgin TV Go on Chrome.

Although it's the Sky Sports site, the VM login page link is resolving to the error page, which I think means it's a VM issue, or at least a combination of both. It looks like the (VM login) page is making an authorization request but receiving a 302 code on Chrome, but a successful 200 code on Chrome Incognito.

Hope that helps

Many thanks for getting back to us mh15, 

Can I ask regarding this, does any other browser show the same error as well?

Let us know,


Hi Kain,

It's only Chrome as far as I can tell. Chrome incognito, Firefox, and Edge all work. I've tried disabling extensions in Chrome thinking that could be it, but still not working.


Thanks for coming back to us @mh15 and its strange that the issue only happens in Chrome and the incognito mode is okay. Are you able to log into My Virgin Media and TV GO using Chrome?

Are you able to share a screenshot of the error that you're seeing?