Showing results for 
Search instead for 
Did you mean: 

Sky Sports App with Stream subscription

Tuning in

I have this issue too. I have installed the sky sports app. Logged in to virgin tv go. Clicked on watch via sky sports. Signed in through the UK Virgin link. Even tried restarting my Windows PC. No luck


You will need the relevant subscription to watch this programme.

Error code: OVP_00005


Please advise.




Forum Team
Forum Team

Hi @smallclone 

Thanks for posting and welcome back to the community. Sorry to hear of the issue watching Sky Sports via their app. Can you confirm, is this viewable on the Stream box itself and just not the app? 

Have you got any VPN's on the device at all? 

Keep me posted.

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill



It seems to be working now. I haven't changed anything. Maybe my details hadn't been put on the sky system as I was originally trying about a day after adding sky sports to be subscription.

Joining in

@smallclone, how long did it take to work for you? Having the same issue and trying to figure out the propagation delay.

Just got it working after ~10 hours delay

Hi @naddinp, thanks for reaching out to us and a warm welcome to the Virgin Media forums. 👋🏼

I'm happy to hear that the Sky Sports is working now.
If you do have any issues with your Virgin Media services, reach out to us here and our team will assist.

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Still not working for me - exact same error. Its now been 10 days. Anyone else managed to get this resolved without magic of some sort?

Hi @Humph1 👋.

Thanks for reaching out to us. Apologies you are having issues in watching sports on your mobile device. Can we ask, when you logged into the Sky Sports app, did you lead off the forwarding process from TvGo and are you using the correct log in details for the MyVM app?

Let us know. 



Yes this was from the redirect on the VirginGo App. But also when using my Laptop and signing in to the Sky Sports website with my Virgin Media credentials. It looks like I'm not the only one who has this issue. Lots of people here have posted about exactly the same issue.

It has never worked in the 10 days I've had Stream and the Sky Sports package: