Menu
Reply
Bozzy63
  • 3
  • 0
  • 0
Joining in
843 Views
Message 1 of 14
Flag for a moderator

Registered Device

I am unable to watch on a device that it says is registered even though I’ve used it before,can someone reset it for me?

0 Kudos
Reply
Lisa_CC
  • 3.99K
  • 236
  • 451
Moderator
Moderator
764 Views
Message 2 of 14
Flag for a moderator
Helpful Answer

Re: Registered Device

Hey Bozzy63,

 

I've managed to find your details and have reset your device list. Please re-add your devices and be careful about watching TV GO on the browser as a new tab may create a "new device".

 

Thanks,

 

Lisa

 

 

0 Kudos
Reply
Bozzy63
  • 3
  • 0
  • 0
Joining in
758 Views
Message 3 of 14
Flag for a moderator

Re: Registered Device

Thanks.😀
0 Kudos
Reply
Hollie_B
  • 932
  • 45
  • 68
Forum Team
Forum Team
658 Views
Message 4 of 14
Flag for a moderator

Re: Registered Device

Hi there @Bozzy63 

 

I can see that Lisa reset your devices for you. Have you since been able to log in and watch on the App since? 

 

Let us know if you need any further help 🙂 

 

Thanks, 

 

 

Hollie - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
SammyM
  • 16
  • 0
  • 1
Tuning in
633 Views
Message 5 of 14
Flag for a moderator

Re: Registered Device

Hi.  The same thing has happened to me.  TV Go is fine on my mobile but it says I have reached maximum devices when I try to use my browsers (on desktop computer).  It says I am using three devices on Goggle and one on firefox, .(Plus my mobile)      It will not let me in to TV Go on either browser but says I can replace in several days time.  This has happened before and I replace when time is up.  But then it happens again.    I note you say using a different tab can effect this.  I have also downloaded new versions of both browsers.  Also from time to time I clear cookies.   Can you please advise.  Many thanks,  Sammy.

0 Kudos
Reply
jhactually
  • 112
  • 0
  • 28
Up to speed
610 Views
Message 6 of 14
Flag for a moderator

Re: Registered Device

This happen to me too...

I use Firefox, all up to date. When I try to watch, it asks me to <Register Device> - IU do that, get a buffering screen, then back to <Register Device>

The only thing that happens is my device count goes up - '3 of 5 devices registered' until I have 5, then I'm stuck.

I was told to go over to using the Windows App, but that now tells me that it won't be working soon?!

I can delete devices on the Windows app, so long as I have <5. I have to clock the 'replace' button which then deletes them.

I can register my device over and over - IT WILL NOT WORK.

jhactually_1-1600953986749.png

jhactually_2-1600954035513.png

 

 

 

 

0 Kudos
Reply
Beth_G
  • 3.13K
  • 196
  • 306
Forum Team
Forum Team
536 Views
Message 7 of 14
Flag for a moderator

Re: Registered Device

Hi SammyM,

 

I'm sorry for our delay in responding to you and for the trouble you've been facing with your device count on TV GO, this is a known issue.

 

Cookies help TV Go to identify which devices are already registered and which devices are new, and so clearing your cache and cookies and running antivirus software can cause TVGO to recognise your web browser as a new device.

 

If you would like us to reset your devices, just give me a shout and I will gladly get that sorted for you.

 

Beth

0 Kudos
Reply
SammyM
  • 16
  • 0
  • 1
Tuning in
525 Views
Message 8 of 14
Flag for a moderator

Re: Registered Device

Many thanks Beth. "Chris" has reset my devices, so here's hoping things will improve. It is a browser problem. I first reported it on this forum back in 2016. The TVGo programme seems very sensitive to any changes. From time to time I update my browser ( as recommended for security reasons), also run antivirus software (again recommended), close tabs, occasionally clear cache, and these seem to make TVGo think I an using a new device. It is something I have had to live with, but it is frustrating that sometimes I have to go two weeks without TV until I can change device. Is it not possible that the TVGo programme can be modified to solve this problem with browsers?
0 Kudos
Reply
Megan_L
  • 2.43K
  • 147
  • 240
Forum Team
Forum Team
488 Views
Message 9 of 14
Flag for a moderator

Re: Registered Device

Hi SammyM,

Thanks for using the forums to get this issue looked into, I am sorry if this is causing you some inconvenience and frustration. I'm also sorry for the delay in getting back to you, but I have some good information. We were aware of this issue on the TV GO App, our IT team have looked into the problem and have since resolved it. Could you please try reinstalling the app and try again please?

Thanks,

Megan_L    

 

 

 

0 Kudos
Reply
Bozzy63
  • 3
  • 0
  • 0
Joining in
433 Views
Message 10 of 14
Flag for a moderator

Re: Registered Device

Hi,yes it did work until today,it’s now asking me to sign in but when I do,it still won’t allow access.

0 Kudos
Reply