Showing results for 
Search instead for 
Did you mean: 

Re: Sky Sports on iPad video Unavailable

Tuning in

I am having the same issue and have tried previous suggestions to no avail


Very Insightful Person
Very Insightful Person

@PlumR14 wrote:

Thanks. There are three options on my Norton. Wi-Fi Security, Device Security, Internet Security. VPN is shown as OFF. I do not understand why this has happened on this device. It used to work fine.

VPN will show as off, but it is still modifying your connection. “Internet Security” is the browsing protection. All you have to do is select this & move the slider to “off”. Then your Sky Sports streams will work.

VM 350BB 2xV6 & Landline. Freeview/Freesat HD, ASDA/Tesco PAYG Mobile. Cable customer since 1993

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Ahah!! I tried turning off individual elements of Norton 360. Bu switching SafeWeb off in Internet Security while watching SkySports app, it seems to work. Thanks to all.



Hi @PlumR14


Thank you for the update.


I am happy to hear this is now resolved 🙂

Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Joining in

I am now struggling with the same problem and have tried several of the previously offered recommendations, but to no effect. Sky Sports on iPad video Unavailable

Forum Team (Retired)
Forum Team (Retired)

Hi @gilakreo,

Welcome to our Community Forums! Thank you for your post and I'm very sorry to hear that this has been your experience with the Sky Sports App. I can understand how frustrating this can be. 

Are you having issues accessing the App on multiple devices, or just on your iPad? 

Have you tried the steps outlined in this thread previously?

Have you tired to delete and then re-install the app to see if this will help with this?

Please let us know so we can help.

Thank you.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Joining in

I am also having similar problem with TVGo on iPad as many others have had - last night for SkySports “video unavailable a problem was encountered please try later”

However it worked 3 days ago watching Sky Sports golf coverage but now and last night won’t let me in to Sky, but will let me into BT or ITV etc.

I do have a VPN installed and it didn’t stop SkySport working a few days ago, but I did both switch the VPN off then delete the VPN from iPad but that didn’t work nor did switching iPad off then on again several times 

At one point it allowed me to sign in via Virgin but a brief disappearing message stated I need the desktop edition installed - ridiculous 

Please advise how to resolve - without the standard guff - and avoid pushing me onto Sky as the problem and contract is with Virgin. (Yes like other users we get very naffed off when forced to miss football matches)

Hi @JohnyF 👋

Welcome to our Community Forums and thanks for your post. Great to have you here. 

I am sorry to hear you are also having this issue. 

Have you tried deleting and re-installing the app? 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hello Alisha , yes I did delete and re-install the SkySport app but same ‘unavailable’ result

Hi JohnyF, thanks for getting back to us. 

Sorry to hear my colleague Ayisha's advice of deleting and re-installing the Sky sports app did not wield a fix for you! Can I just check if the issue is isolated to the ipad or if you are also having issues with the App on other devices also connected to your network?

As you were previously using a VPN on the same device, it may be that this has caused the device to be recognised as a 'new device' rather than an existing one in terms of your registered devices.  You can have up to 5 different compatible devices signed up to the TV Go service and use the app at one time, with the ability to make adjustments to your registered devices 3 times in one month. You can find more information on how to register or replace a device here 👉 Once registered you will need to keep the cookies on your device or it can register as a new device every time and use up all of th available changes. More info on this can be found here 👉 TV Go registered devices - Virgin Media Community - 4457311
If you need us to manually clear all registered devices for you, please let us know and we can arrange helping with this following the confirmation of some account information. 🤞 Hopefully this is the root cause of the issue and helps resolves things. Let us know if not and we will continue to offer support! 

All the best. 🌞


Thank you Molly for following up and this explanation is potentially the cause although ?? I suspect it may be due to other reasons because the same iPad worked on TVGo /SkySport a couple of days before (using motorhome Wi-Fi mobile dongle),  then wouldn’t work with same Wi-Fi unit in a different location, then did start working again a few days later when using home WiFi (no further changes made e.g. not reinstalling VPN )