Menu
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
284 Views
Message 1 of 4
Flag for a moderator

On demand service on devices asking me to upgrade - I have full package?

Hello 

I have the biggest tv package with movies and STARZPLAY - these services via on demand work on the TV through the virgin box however they don't on my devices, keeps saying I need to upgrade? I have phoned Virgin Media and spoke to 2 agents more than 5 days ago and they said it was a wider issue however no issues are being raised on their website as stated. Paying for a service i'm not receiving fully, Please note on demand on the devices was working over a week ago. Any thoughts or advice? Thanks

0 Kudos
Reply
Highlighted
  • 464
  • 24
  • 47
Forum Team
Forum Team
230 Views
Message 2 of 4
Flag for a moderator

Re: On demand service on devices asking me to upgrade - I have full package?

Hi krajput 

 

Thanks for joining our community and posting. 

 

Sorry to hear you've been having issues with your TV Go App - we did have some known issues last week that may have impacted the service like this. Have you since tried to use it? Please let me know if there is an error message popping up and how things are for you now. 

 

If you are trying to watch Sky Cinema or Sky Sports you will be able to download their App and still log in to watch. 

 

Let me know and we'll go from there 🙂 

 

Thanks, 

 

Hollie_B

Hollie - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
205 Views
Message 3 of 4
Flag for a moderator

Re: On demand service on devices asking me to upgrade - I have full package?

Hi Hollie

Thank you for the reply. Its still the same. Movies works as it exits to go onto another app. 

Thanks

0 Kudos
Reply
Highlighted
  • 1.32K
  • 89
  • 130
Forum Team
Forum Team
173 Views
Message 4 of 4
Flag for a moderator

Re: On demand service on devices asking me to upgrade - I have full package?

Hi krajput,

 

Sorry to hear that you're still affected by this issue.

 

Have you got the most recent updated version of the app? Can you please try uninstalling the app and then reinstalling it again?

 

If you're still having issues after reinstalling, can you please try the following

 

  • Log into TV Go
  • Go to Settings
  • Select 'My TV Channels
  • Select 'Reset to Default'
  • Log out of TV Go and back in

 

Let me know that goes.

 

Regards,

Beth

0 Kudos
Reply