cancel
Showing results for 
Search instead for 
Did you mean: 

Firestick 4K working fine for months with Virgin broadband, now I cannot connect??

TheOneKadio
Tuning in

I have had an Amazon Firestick 4K Max for around 4 months now and everything has been fine. However, since 8/2/23 it's not connecting. I haven't touched it, changed any settings or anything. It was literally working one minute and the next it wasn't. I've tried hot spotting the Firestick to my phones internet and it works fine. Also, I've connected the Firestick at my girlfriend's house (she has Virgin internet too) and it works fine there as well, it just doesn't work at my house and on my internet (Virgin).

Any suggestions as to what could be causing it to not work all of a sudden???

25 REPLIES 25

Hi. 

I have the same problem, since I connected in an other area of the house a WiFi extender that works well. After one week, suddenly, my firestick 4k is connected but is written NO INTERNET. Every appliances work well with a good connection, only the firestick doesn't. But if I connect it to the WiFi extender, it does work properly. I tried to reset the firestick and cut off the extender, but nothing. Connected but no Internet.

Hi @ciropignalosa 

Thanks for posting and welcome back to the community.

Have you tried the below advice from Newapollo?

 

Are you using the firestick HDMI extender which helps cut out interference from TV's and STB's?
Have you tried connecting to the guest network on your hub? 

Have you tried factory resetting your firestick?

Press and hold Back and right side of the navigation circle together for 10 seconds.
On the TV screen, choose to continue or cancel the factory reset. If you don't choose, the device resets automatically after several more seconds.

 

Best,

John_GS
Forum Team


Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

ciropignalosa
Tuning in

Hi The oneKadio, I had you same identical problem. It worked for 3 months, the suddenly the firestick 4k max doesn't connect to Internet. I tried everything like you. Connecting with my phone hot spot (very good), but not directly to my hub 3. It can see my Virgin Media provider but no connection, and now after yet another reset, it does connect but it says "connected to WiFi but not connected to the Internet." very frustrating. Did you sort it out. Please let me know if you did it. Thanks 

Roger_Gooner
Alessandro Volta

Connecting the Stick to a USB 2.0 Micro-B Ethernet adapter should solve the problem. I bought one from Cable Matters.

--
Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

Client62
Legend

Connects to the WI-Fi but then does not gain internet access.

These are the exact  symptoms of a device that has been paused with the VM Connect app / or Hub menu.

Thank you so much. I'll try to buy it. Really appreciate. So this is what I have to buy... USB 2.0 Micro-B Ethernet adapter... Isn't it.