Showing results for 
Search instead for 
Did you mean: 

Firestick 4K working fine for months with Virgin broadband, now I cannot connect??

Tuning in

I have had an Amazon Firestick 4K Max for around 4 months now and everything has been fine. However, since 8/2/23 it's not connecting. I haven't touched it, changed any settings or anything. It was literally working one minute and the next it wasn't. I've tried hot spotting the Firestick to my phones internet and it works fine. Also, I've connected the Firestick at my girlfriend's house (she has Virgin internet too) and it works fine there as well, it just doesn't work at my house and on my internet (Virgin).

Any suggestions as to what could be causing it to not work all of a sudden???


Up to speed

Hi TheOneKadio, 
I’ve got the same problem with my 4k Firestick, I only noticed the problem a week or so ago. I’ve tried deleting the 2G and 5G wireless connections and reinstating them, the Firestick connects ok wirelessly to the router but there is no internet connection. All other devices in the house connect wirelessly to the internet ok. I am going to try connecting using my neighbour’s broadband tomorrow to see if it will work.



I honestly don't get it. Like I said, I've tried Hot Spotting the Firestick to my phones internet and it works, I tried it at my girlfriend's house, on her her Virgin Wi-Fi and it worked, it's just on my home Wi-Fi that it doesn't work. Literally from one minute to the next, so frustrating. Let me know if you figure it and I'll do the same.

What happens on yours? Do you have IPTV? Are your apps working?

Good luck!

A little into on the WiFi situation if you please ...

Which Hub is involved in the failing connection ?

Are there any WiFi pods or extenders ?

Or is the Hub in modem mode and with a 3rd party router or WiFi mesh etc ?



I have had Virgin's Hub 5 since around  October. The Firestick is connected to the hub in the living room. Upstairs, I have one pod plugged into the wall on the landing.



My Firestick worked ok via my neighbour’s EE broadband , I reset my Hub 3 using the hole on the back and the Firestick now connects to the internet ok. No idea what caused the problem with the Hub.



I've tried that mate, still no connection. 

Having marked this thread as having a helpful answer ( Green Tick ) means the VM Team will give this thread little or no attention.

Unless the problem is fixed,  consider removing the helpful answer mark on the earlier post to attract the VM Team.

Can the Firestick's connection for the Hub be forgotten / deleted so the current SSID / password can be re-entered ?

I don't use WiFi unless I have to, so I've got my Stick connected to my router with a Cable Matters Micro USB to Ethernet Adapter which works flawlessly.

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

Forum Team (Retired)
Forum Team (Retired)

Hi there TheOneKadio,

Thanks for your post and welcome back to the community.

Apologies for the issues faced with the connection, can I ask are any other devices affected?
Also is this happening within the same room as the Hub?