Showing results for 
Search instead for 
Did you mean: 

Failure to communicate

On our wavelength


I have a recently arrived stream box which, from unboxing, refuses to pair with the stream box. 

The remote will advertise to a mobile phone, pair, and the phone reacts to the keyboard commands.

Support are sending me a replacement remote, which is demonstrably not problematic, and will not entertain a replacement stream box until the remote arrives and is proven to be ineffective. Update, I conviced someone to tell me there is a new box on the way, time will tell.

So ... I have unpaired the remote from the phone, (using rewind and TV buttons, three white flashes). Still won't pair.

So, two questions ...

Is there anything I can do to the stream device to convince it to pair or is it likely defunct?

Is there a visual cue from the stream box ( a pairing flash would be nice) to indicate that it is attempting to pair (after 10 second power depression)? 







On our wavelength

Well... The replacement box has arrived, as before system updates, reboots, this time the device does pair with the remote control, but the 5 second power press panel stays on screen until I get bored, press a button, and the remote 10 second panel returns. On reboot the device says "Install complete!"  then moves to the pairing loop but the remote is still able to power it/tv on and off, change hdmi on the tv etc. It's paired but the device is still demanding pairing even though it's listening to the remote and passing commands up the HDMI.

Support says it will be working in 24hours. I suspect it won't.






I am able to turn the device off, the TV controls operate, but can't get past the pairing screens.



Forum Team
Forum Team

Hi @armstrongfj 

Welcome back to our community forums and sorry to hear you are having issues with your new Stream box. We can understand the inconvenience caused and we want to do our best to help. We are glad to see you got the replacement box. We would advise waiting for 24hrs as suggested by our team to see what happens. If the issue persists, please let us know and we will do our best from here.


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Thanks, alas no change, it still wishes to repair post pairing (ironically triggered by a post paired remote control key press).


Is there a method for putting the box back in factory default please?

 I suspect set No 3 is on its way (or something from Virgin Media. I''ll keep you informed. 

Hi @armstrongfj 

Thanks for coming back to the thread.

See below;

Unplug the USB from the back of the box .

Hold the power button on the front of the box while  plugging the USB back in . (Don't let go of the power button while doing this .

Keep holding the power button in on the Welcome screen for 5 seconds  only then let go.

A menu will appear. Tap the power button to select  which reset (hard-soft) option you prefer.

Then hold the power button again for 5 seconds on the one selected option to reset it. 

Let me know how the reset goes.

Best wishes.

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill


Many thanks, OK, I unplugged the ethernet and tried a hard reset - demanded ethernet, reconnected, rinse repeat ...

Please wait ...


powered down

please wait


Downloading latest update

Installing software

Virgin Media logo

Install complete!

wait, 10 sec remote control panel

key presses, didn't have to press power button on device, it just paired

10 second remote control panel Loop.

Soft reset 

Downloading ...

Installing ...

Logo ...

Oooh ... 5 sec press on box

Paired message . Picture of John Wick 4, Trouble is ... whatever it paired with, it isn't the remote, at least the buttons don't work, also the remote is still slow flashing which I take to be bluetooth advertising.

Tried again, this time I setup the remote control advertising on the software install, same outcome.

OK, tried pairing again, same outcome, Tried pairing again, success.


So ... Thanks very much, for the information!









Hi Francis,

Thanks for taking the time to update us, glad to hear this is sorted 🙂