Showing results for 
Search instead for 
Did you mean: 

Channel 4 Grey Screen

Tuning in

Hi all! Trying to watch live TV. Channel 4. Every 10 seconds I get grey screen, but the audio remains. If I channel hop up and down the picture comes back and then grey screens again. 

I’ve tried all the reboots etc… issue remains. 

has anyone seen a fix for this?


Forum Team
Forum Team

Hi @Winn123 

Welcome to the community forums

Sorry to hear you're having issue with channel 4 on your set top box. 

Does this issue only happening on channel 4? Do you see any error codes at all on screen or is it just grey? 

- Double check that their cabling is all connected properly. Advise them to remove the cable from both the STB and the TV and then plug it back in ensuring it is seated properly.
- If you have any home AV equipment ensure this is configured correctly to receive audio.
- Once you've done this, please turn your TV and the set top box off for a few seconds and then power up again to refresh the HDMI handshake between the set top box and the TV.

Here to help 🙂
Virgin Media Forums Agent


Only on channel 4! I’ve done the below, made no difference. 


Thanks for trying this @Winn123 

Really odd one this. 

Can you please try another HDMI cable and possible also try the HDMI in another port to see if that clears the issue?

Here to help 🙂
Virgin Media Forums Agent

Joining in

I have exactly the same problem, tried everything. Only happens with channel 4 when live. It’s driving me and the wife mad at the moment and want a fix. 

Virgin customer service has been far from helpful since changing from sky and that’s even if you can even have the opportunity to speak to a human. 

can’t wait to be out of contract!

Tuning in

I called customer support. They couldn't get me off the phone fast enough saying "Channel 4 is down in the last 24 hours". I've had the issue for weeks... I was asked to call back "in a few days if the issue persists". I'll post after I speak with them...

On our wavelength

I've also posted a reply in another post as I'm having the same issue. I've tried everything including a reboot. Is there a fix for this?

Thanks for coming back to us Winn123, is this issue still happening for you at the moment?

Kind Regards,


Yep! Hugely frustrating I can't get any support. 

Forum Team (Retired)
Forum Team (Retired)

I'm sorry to hear the issue is still occurring, Winn123. I've taken a look on our side, and can see you have spoken with our team since posting, who have been able to assist further with this.

Please let us know if you continue to experience the issue and we'll do our best to assist you further.


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ