cancel
Showing results for 
Search instead for 
Did you mean: 

slow ethernet and wifi on hub 4

ZZIP2017
Tuning in

I recently upgraded to gig1 internet but the speeds are so slow, wifi on my phone is lucky if it makes 250 download and thats me right beside the hub 4, but the real problem is the ethernet. I run everything on ethernet instead of wifi, always have and have never had a problem. The problem being is anything plugged into the back of the hub does not go above 100 apart from the VM 360 box which i get 230 download speed, but that is nowhere near what i should be getting, I have unplugged everything and just plugged my pc into the back of the hub and it just makes 97 down, the pc is capable of 1 gig and i have enabled that in the properties section of the ethernet adapter. 

i have tried various speed tests including "samknows" which says the speed to the hub is 1144 but to the pc is 97. When i access the hub it says various equipment connected by ethernet is receiving 1000mbps or is capable of receiving it but it is not going above 100 infact alot of equipment is alot lower. The cables connecting the equipment are all decent not cheap rubbish and all my equipment is  maximum 2 years old so it aint old tech.

i have tried various cables including cat 5e, cat 6 and nothing will give me the speed i pay for, i do realise that i will never get 1000mbps on wifi but on ethernet i should be getting close to it.

I phoned up today and the lady i spoke too was more interested in the wifi problem rather than the ethernet . And the wifi problem aint changed any after being told they will run tests

to be honest i am within my cooling off period and if this is the speed i will get then i think i will be cancelling too, i have read a few posts online about ethernet problems with the hub 4 that goes on for months or does not get resolved, thats hardly a way to keep customers happy.

Stuart

 

1 ACCEPTED SOLUTION

Accepted Solutions

run PC in safe mode with networking and hub in modem mode without a router and post the speed link of what you get
https://www.speedtest.net/
---------------------------------------------------------------

See where this Helpful Answer was posted

25 REPLIES 25

carl_pearce
Wise owl

run PC in safe mode with networking and hub in modem mode without a router and post the speed link of what you get
https://www.speedtest.net/
---------------------------------------------------------------

I have rebooted the pc in safe mode with the hub 4 in modem mode, obviously that cuts out the wifi but nothing connected to the ethernet ports are working either, the pc says it has no network adapters available and the virgin tv boxes wont connect saying no network same for tv's although the lights flash on the network switch that there is activity and the light goes out on the switch when i disconnect the ethernet cable from the switch to the router.

However when i connect the ethernet cable from the back of the router that goes to the pc into a usb to ethernet adapter into a usb port on the pc it comes up as ethernet 2 adapter in network settings on the pc and when i do a speed test it comes up with a speed on speedtest.net as roughly 450mbps, broadbandspeedchecker.co.uk comes up with a 70 mbps, fast.com says 220, so various results, samknows wont connect at all saying it cant connect to the router

legacy1
Alessandro Volta

Sound like VM network links to routers from your area are under heavy load.

---------------------------------------------------------------

I have an engineer booked for the 20th so hopefully get it sorted out, thanks for your help

Adduxi
Very Insightful Person
Very Insightful Person

You need to use “Safe Mode with NETWORKING support”.  You don’t need to use Modem mode either for this test, as you are using cable. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

I will check that tomorrow,  thanks for your help

I had an engineer out and changed the router but no joy still slow internet so i googled slow ethernet on windows 11 and found this article

https://www.drivereasy.com/knowledge/easy-fix-windows-10-slow-internet/

 

fix  5 is what you want to sort it but do the opposite, the fix says disable it you want to enable it

key in command prompt   netsh interface tcp show global into the window and press Enter. Then check if Receive Window Auto-Tuning Level is set to normal. mine was set to disabled, if yours is set to disabled then key in the following:

To make it a bit more clear, type netsh int tcp set global autotuninglevel=normal into an administrative command prompt to fix issue.

 

my speed is now 1.1 ggig according to fast.com and samknows, i have spent over a week trying to sort this out, my whole house is wired for ethernet and i have checked every wall jack and every cable and only found 1 fault but that wasnt the problem, this is a new pc and i got it a week before i upgraded to gig 1, am chuffed to bits  now, will have to hava beer or 2 to celebrate !!

Hi there @ZZIP2017 

 

Thank you so much for your post and welcome back to the forums.

 

I'm so sorry to hear you were facing issues with your service but I am glad to hear you were able to arrange an engineer. 

 

Can I just check is everything now working as it should be?