Showing results for 
Search instead for 
Did you mean: 

Very slow download speeds on Gig1

Tuning in

Hiya; I've noticed that my download speeds lately have been nowhere near the Gig1 quoted achievable speeds. Testing earlier, I saw speeds such as this when tested via


I'm using the Hub 4 in modem mode, using my own Asus router (running latest firmware). 
I've tried restarting the modem, factory resetting the modem, each with no success. 

Could someone point me in the direction of what extra deets I need to gather to request support on this, please 🙏

I've looked on the virgin media website and although referenced frequently, the Live Chat seems to be suspiciously absent 😡


Tuning in

VM low Speed.png

Yesterday's BQM:
20230301 BQM.png

Today thus far's BQM:
20230302 BQM.png

Hi HalpMeee,

Thank you for your post. I'm very sorry to hear about the speed issue you're having. 

To confirm, if you disconnect your 3rd party hub and run the test what speed are you getting?

Are these tests on a Wired or Wireless connection?


Hi Martin,

The speeds direct from the modem with it set to router mode are similarly pants:

All of the connection speeds quoted will be via wired connections. 

Very Insightful Person
Very Insightful Person

Try checking with Area faults on 0800 561 0061 or if you have a VM landline 150 as small local faults are not listed on the VM status page.

Post the power levels, Pre and PostRS errors and network log from the Hub.  Once done we can comment.

Also with the Hub in Router mode what results do you get from


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Hi @HalpMeee 

Thanks for coming back to the thread. Did you follow Adduxi's advice and get this resolved?

Please pop back to the Community if not and we'll be happy to assist. 

Best wishes.

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

"I'm using the Hub 4"

That is probably the issue


Apologies for the delay in replying. I'll have to give the local area faults line a try - at present I haven't remembered to do so. Will post what they say if anything useful. 
Anyhoo, onto the collected requested info:

I've included:

a copy of the BQM data for the past 24 hours,

Router Power Levels,

Router Pre and PostRS Errors

and a snip of the samknows data (once it recognised I'm not on a VPN or other and worked...)

BQM 20230403.png

Router Power Level 20230403.png

Router Pre and Post RS Errors.png


The samknows data is really perplexing. The PC is the only thing attached to the cable modem and was freshly rebooted. It's a Windows 11 gaming PC, not built too long ago and certainly isn't short on resources. 

I've started experiencing cut-outs in the connection, also. This results in me being hoofed off the work's VPN, which is extremely annoying. 

BQM 04-04-2023.png

First outage due to me faffing around with the modem yesterday evening, trying to get more info for this to maybe be looked into. Good job I wasn't due to be working in the early hours, right?!