Menu
Reply
rickharso59
  • 1
  • 0
  • 0
Joining in
296 Views
Message 1 of 2
Flag for a moderator

Upload speed has been awful for weeks

I've chatted with Virgin countless times over the last few weeks and can't find a solution to poor upload speeds, so I was hoping someone here could help.

The last time I got through I was even told that they couldn't do anything (!) about my upload speed and could only assist with if my download was the issue.

Basically, my download is great. I'm on the M200 package, so I'm meant to be getting around 200mb down and am consistently around 210. But, I'm also meant to be getting an average of 20mb up and it's hovering between 2-5 most days. That's over ethernet, too. Not wi-fi.

I haven't been able to get a clear answer from them on whether or not this is just because of lockdown and everyone working from home. If that was the case, then I suppose I'd have to just grin and bear it, like everyone else, but they're just not telling me.

Should I get a different router? Would that improve things? Apologies: I'm not great when it comes to fiddling about with broadband. I normally set it up, plug in the ethernet, and I'm good to go. And the Virgin service was good, but I feel like just before the pandemic it started to dip drastically and now its dreadful.

Is anyone having similar issues? And also if anyone had any tips for improving upload speed, that'd be really appreciated!

0 Kudos
Reply
DJ_Shadow1966
  • 7.2K
  • 1.37K
  • 2.06K
Very Insightful Person
Very Insightful Person
281 Views
Message 2 of 2
Flag for a moderator

Re: Upload speed has been awful for weeks

Hello
How are you doing the speedtest is it either wired or wireless, wired is always the best option.

Can you please post your network stats from the hub
Open a Web browser (e.g. Internet Explorer) and enter the address http://192.168.0.1
Note: If you have enabled Modem Mode on your Hub 3.0 you will need to use 192.168.100.1 instead.
Posting the stats by copy and paste will remove all personal information so no breaches.
Do not login but click on where it says "Check Router Stats" and then copy and post from the following 4 tabs, Downstream, Upstream, Configuration and Network logs (if they are pasted then all personal information is * out) and we can check your power level, also while you about that can you please go around and check that all connectors to VM equipment are hand tight. Also while doing this please check for any damage to cable, or un-terminated connection without either coax or a terminator.
Also please run "Check service status" at the top right of this forum and call 0800 561 0061 to check for local issues.
Also one think you can do is too signup at https://www.thinkbroadband.com/broadband/monitoring/quality and setup a broadband quality monitor which will keep an eye on you connection by sending a small amount of data to the hub asking if it still on.

Regards Mike

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply