cancel
Showing results for 
Search instead for 
Did you mean: 

Upgraded to 1Gb Broadband and service worse than on 500mb

Ldrew500
Joining in

I upgraded to the 1gig broadband from the 500mb one. From day 1 of the upgrade i've had nothing but hassle. I'm getting nowhere near 1Gb i'm getting lower speeds than i had on the 500mb broadband, it's been passed to technical and i've had 2 engineers out and still no further forward can anyone offer any advice as to what I can do to get this resolved. I have lost count of the number of times i have called up and been promised call backs and they never get back to me. 

2 REPLIES 2

Nathan_B
Forum Team
Forum Team

Hi there @Ldrew500 👋 Welcome to our forum and thanks for your post 😊

I'm sorry to see you've not had the level of service we'd expect when you've spoken with the team to get this issue resolved. I'll certainly be happy to take a look at this further for you.

I'll send you a PM to confirm your details so this can be done.

Regards

Nathan

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


Client62
Hero

Samknows Realspeed

First call 0800 561 0061 - use the automated service to see if there is a local service issue.

Use the test below to see if the issue is at the Hub or device.

Speed test the service to a Router mode Hub(3/4/5) + your device with the link below.

https://www.samknows.com/realspeed/

Once the test begins click on: Run full test to see all the stats.

The speed at the Hub should reflect your subscription.

The speed any WiFi device draws data at is limited by its data needs and technical abilities.