Menu
Reply
G944S2
  • 30
  • 0
  • 12
On our wavelength
302 Views
Message 1 of 2
Flag for a moderator

Terrible upload speeds

I received a text from Virgin saying they were carrying out essential works in my area on Monday and a further message to say they were finished.

No idea if there’s a connection but my upload speeds have now dropped from 40Mbps to under 1Mbps.  I’ve done many reboots, switching off everything etc and did briefly see speeds returning to normal this morning but it didn’t last long.

Looking at this forum I don’t seem to be the only one having issues but not sure if it’s a general problem or not.  I’ve not called virgin apart from the automated service status yet as the last time I tried that it was a dreadful experience that I’d rather not repeat until it’s a last resort.  The service status reports no issues.

AFEE0623-904A-4FAA-9A21-A9ADBA13DFB0.jpeg

 

0 Kudos
Reply
Molly_G
  • 1.15K
  • 53
  • 136
Forum Team (Retired)
Forum Team (Retired)
245 Views
Message 2 of 2
Flag for a moderator

Re: Terrible upload speeds

Hey @G944S2,

 

Many thanks for your recent post - I'm really sorry to see that you're not getting the upload speeds you should be, especially after some recent work we've carried out.

I've ran some checks from our end and can see that there are some upload and SNR issues being flagged, which I'd like to book a visit in for.

I'll just send you a private message so I can get this booked in, so please keep an eye on the purple envelope at the top of the page.

 

Many thanks,

 

Molly_G
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply