Menu
Reply
N3m3sis1
  • 10
  • 0
  • 1
Tuning in
393 Views
Message 1 of 7
Flag for a moderator

Slow Speeds from Hub4 to PC on 1Gb/s - A partial Solution and Virgin techs take note!

I upgraded my package to the 1Gb/s service on 04/07/2021 and was appalled at the speed from the hub to my pc, which was around 300Mb/s! Changed cable from cat 5e to Virgin media Cat 6 cable, no change in Hub4 to computer speed. Trawled through posts here and on a more general line through the internet, all the same suggestions - go to modem mode (does not work), change cable, change hub port, update drivers, disable Qos, etc etc. Nothing worked until I tried this.....

You will need to be confident in usings windows command in the cmd window and here is what I did, which I got from this page here... https://www.ontimetech.com/blog/is-windows-10-slowing-down-your-computers/

Open a cmd window using admin privileges and at the command prompt type "netsh int tcp set global autotuninglevel=disabled" without the quotation marks and hit enter. Then do a Samknows/Realspeed test but keep the command window handy. You will get the same speed to the hub but an even more reduced speed Hub4 to computer. Open the the command window again and at the command prompt type "netsh int tcp set global autotuninglevel=normal" again without the quote marks and hit enter. Then go back and re-run the Samknows/Realspeed test.

This is what I got..

N3m3sis1_0-1625510320879.png

 

N3m3sis1_2-1625510534035.png

 

N3m3sis1_1-1625510401911.png

 

So it defintely is a windows auto-tuning thing (by the way I am on Windows 7 64Pro).

It will be interesting to see....

1.If anyone running Windows 10 can get the same results and

2. More interesting if those clever techs at virgin can find a way or implement a fix to the Hub 4 to

make entering a command prompt window unneccessary.

Please let me know if this helps you.

 

0 Kudos
Reply
legacy1
  • 16.27K
  • 710
  • 1.6K
Alessandro Volta
384 Views
Message 2 of 7
Flag for a moderator

Re: Slow Speeds from Hub4 to PC on 1Gb/s - A partial Solution and Virgin techs take note!

By default windows 7/10 is autotuninglevel=normal its only set to disable if something on your PC set it to that.

With autotuninglevel=disable depending on the latency you may only get 30Mb per thread so Samknows/Realspeed must use only 10 threads.

---------------------------------------------------------------
0 Kudos
Reply
N3m3sis1
  • 10
  • 0
  • 1
Tuning in
375 Views
Message 3 of 7
Flag for a moderator

Re: Slow Speeds from Hub4 to PC on 1Gb/s - A partial Solution and Virgin techs take note!

That maybe however I could get nothing more than 327mbs Hub4 to computer until I disabled and re-enabled the auto-tuning.
0 Kudos
Reply
N3m3sis1
  • 10
  • 0
  • 1
Tuning in
327 Views
Message 4 of 7
Flag for a moderator

Re: Slow Speeds from Hub4 to PC on 1Gb/s - A Solution and Virgin Techs please take note!

I have thought about this a bit more and come to a conclusion. Given that Windows auto-tuning is in place when you have your previous broadband package(or perhaps none), changing your broadband speed would mean that you have to disable autotune and re-enable it to let windows networking know that the networking environment has changed. Since I have searched through this forum and others and not found anyone suggesting to do this, I do not think it is done and it could well be the source of peoples problems when they upgrade to a greater speed.My speed from Hub 4 to computer has remained at that level since I did it and I would suggest people try it. One other thing, clear your browser cache before running Samknows/Realspeed so you get a clear reading.

0 Kudos
Reply
N3m3sis1
  • 10
  • 0
  • 1
Tuning in
253 Views
Message 5 of 7
Flag for a moderator

Re: Slow Speeds from Hub4 to PC on 1Gb/s - A Solution and Virgin Techs please take note!

In true Columbo stye, ermmmm just one more thing.

The above results from Samknows are from a HUB 4 in router mode not modem mode as everyone seems to be advocating.

What is the point have having 1gb/s speed if it is only for one device?.

I am constantly monitoring my speed and it has not changed from the above speeds posted.

Try it!

0 Kudos
Reply
paul0363
  • 538
  • 64
  • 180
Rising star
115 Views
Message 6 of 7
Flag for a moderator

Re: Slow Speeds from Hub4 to PC on 1Gb/s - A Solution and Virgin Techs please take note!


@N3m3sis1 wrote:

 

What is the point have having 1gb/s speed if it is only for one device?.

 


Normally in modem mode you would attach your own third party router or mesh system and not just a single PC.

0 Kudos
Reply
N3m3sis1
  • 10
  • 0
  • 1
Tuning in
110 Views
Message 7 of 7
Flag for a moderator

Re: Slow Speeds from Hub4 to PC on 1Gb/s - A Solution and Virgin Techs please take note!

I donta lika da middle man. 🙂
0 Kudos
Reply