Menu
Reply
mike111111
  • 15
  • 0
  • 0
Joining in
471 Views
Message 1 of 7
Flag for a moderator

Slow Slooooow broadband at high cost

I have tried to get the speeds sorted on our allegedly M100 broadband. Sometimes the internet is so slow you cannot run a speedtest.

I read the help and switched off hub and devices and reset - no change

engineer came and said problem at the cabinet and fixed problem at the cabinet  - no change

rang helpline and discussed 2g and 4g and did something - no change

The story is we have to many devices. Yes but they are not on. We always had these devices. Devices = phones, ipad and desktop pc, sonos speakers. We are not streaming or gaming or whatever. Basic internet stuff  - emails, twitter, a bit of you tube download. There are 2 of us!

The other story is covid overuse.

I am fed up with resetting, restarting, retraining to be a computer engineer - I don't want to go to 192.168.0.1 and change the settings or switch manually from 2g to 5g or rebuild my PC.

Can virginmedia please tell me exactly what is going on and be honest.

0 Kudos
Reply
oswaldp
  • 20
  • 1
  • 6
On our wavelength
462 Views
Message 2 of 7
Flag for a moderator

Re: Slow Slooooow broadband at high cost

You may be better posting this question in the Broadband forum rather than TV to get better responses.

Does your PC/laptop have an Ethernet port that you can connect directly between your device and VM router? This would rule out any WiFi interference issues and you should be able to run a speed test.

0 Kudos
Reply
mike111111
  • 15
  • 0
  • 0
Joining in
423 Views
Message 3 of 7
Flag for a moderator

Re: Slow Slooooow broadband at high cost

Thanks for the reply Oswaldp

I thought I was in the broadband section? Top says

 

That was another solution, cable in the PC but wifi is slow, so faster PC won't help. If the wifi is down to 30 and the phone won't load up a short video. I have run the speedtest and it varies wildly from 100 sitting on the router to 30 and then down to 6 in a bedroom.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.95K
Alessandro Volta
412 Views
Message 4 of 7
Flag for a moderator

Re: Slow Slooooow broadband at high cost

What speeds do you get at >> speedtest.net << with a direct connection using a Cat 5E or better ethernet cable between the Hub in Router Mode and a 1Gbs capable Pc/Mac/Chromebook and no other devices connected ?


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
mike111111
  • 15
  • 0
  • 0
Joining in
292 Views
Message 5 of 7
Flag for a moderator

Re: Slow Slooooow broadband at high cost

Hi MikeRobbo

Finally got a cable connection to PC and speed up and consistent at 90mbps and 10mbps upload. This is good. I will keep PC wired.

I haven't yet had a chance to reset all wifi devices and recheck speeds.Will keep working on it. Any further suggestions welcomed.

The other thing I found out on reddit https://www.reddit.com/r/VirginMedia/comments/j28qsb/internet_fine_on_ethernet_but_not_on_wifi_a/ was concerning channels:

So on all Smarthub's that broadcast wifi, it does this on something called channels.

The hub is set to automatic mode and so it is designed to check for crosstalk and change the channel accordingly to ensure that your Wifi isn't affected however it doesn't work that well.

I downloaded a free app on the play store called NetSpot. This displays all the details for all of the networks that are broadcasting around you.

It displays the signal strength, the band and the channel.

Surprise Surprise all of the Virgin Smarthub's in my flat block were all using channel 42 on the 5Ghz range.

In simple terms, it's like everyone talking at the same time in a small area.

To fix this, I logged into the smart hub (Details on the bottom of the hub) and navigated to Advanced Settings > Wireless > Wireless Signal.

Initially you will see that all of the settings are greyed out.

Scroll to the bottom and select Disable Channel Optimization and when selected all of the options will then become available.

From looking at the app and seeing what channels are being used in your area, you simply need to select manual for each Wireless Frequency range and then select a channel which isn't being used or which has the least amount of devices using it.

Once done click save and then try and do a speed test or use your devices once the configuration has been changed.

I immediately saw maximum speed restored on both my phone and my laptop via wifi and in my case the problem was solved.

This is not a one size fits all fix and your mileage may vary.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.95K
Alessandro Volta
290 Views
Message 6 of 7
Flag for a moderator

Re: Slow Slooooow broadband at high cost

Glad the cable connection has solved a lot of the problem.

Can you Login to the Hub Settings and navigate to the Connected Devices page - what is the reported 'connection speed’ for the ethernet cable connected device you used for the speed test ?


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
mike111111
  • 15
  • 0
  • 0
Joining in
243 Views
Message 7 of 7
Flag for a moderator

Re: Slow Slooooow broadband at high cost

Hi MikeRobbo

All hardwired connections are 1000 and wifi are 100

The desktop PC is 1000

0 Kudos
Reply