Menu
Reply
Chelseakerwin1
  • 2
  • 0
  • 0
Joining in
194 Views
Message 1 of 4
Flag for a moderator

Slow Internet

Hi there,


I am experiencing extremely slow internet, to even loosing connection on Wifi constantly throughout the house.  Can be sat in the same room as the router and still have zero connection. 

I currently have the M350 with minimum download speed of 181Mbps, just done a Speed Test and only getting 22.8Mbps. Upload should be 35Mbps and only getting 8.2 Mbps

I have followed all the steps of resetting the router for it to go up to speed for a couple of seconds and come straight back down again.

Please can someone advise?!

Thanks,

 

0 Kudos
Reply
Zak_M
  • 2.29K
  • 143
  • 229
Forum Team
Forum Team
106 Views
Message 2 of 4
Flag for a moderator

Re: Slow Internet

Good afternoon @Chelseakerwin1 

 

Welcome to the forums and thank you for taking the time to post. 

 

Are you able to let me know, are you having issues with your wired speeds as well as wireless? 

 

Kind regards,

Zak_M

Chelseakerwin1
  • 2
  • 0
  • 0
Joining in
103 Views
Message 3 of 4
Flag for a moderator

Re: Slow Internet

Hi Zak,

Yes both wireless and wired.

Thanks,
Chelsea
0 Kudos
Reply
Natalie_L
  • 2.33K
  • 97
  • 170
Forum Team
Forum Team
36 Views
Message 4 of 4
Flag for a moderator

Re: Slow Internet

Hi Chelseakerwin1, 

 

Thank you for your reply. 

 

I have taken a look at your service from our side and there appears to be a problem with your downstream power levels. Currently they are too high and we will need to arrange a technician to come and take a look. 

 

I will pop you over a private message now to confirm some details and we can get this booked in for you. 

 

Speak soon 

Nat