Menu
Reply
KM84
  • 2
  • 0
  • 0
Joining in
268 Views
Message 1 of 4
Flag for a moderator

Poor broadband speed

Wifi speeds very poor - max 100 when paying for 500
Wifi terrible. BT so much better who we left you for on the promise of better allround service

0 Kudos
Reply
conman33158
  • 1.55K
  • 131
  • 295
Super solver
254 Views
Message 2 of 4
Flag for a moderator

Re: Poor broadband speed

Virgin do not guarantee speeds over wifi, only speeds via Ethernet (wired connection) too many variables with wifi.

What speed do you get with a Cat 5e or better cable from the router direct to your PC, preferably a PC with a 1Gbps network card?

***********************************************************************************************************************************
Super Hub 4.0 (modem mode) - Gig1 Fibre FTTP - Asus RT-AX82U & Asus RT-AX56U with AiMesh setup
***********************************************************************************************************************************
My Broadband Ping - conman33158
0 Kudos
Reply
conman33158
  • 1.55K
  • 131
  • 295
Super solver
247 Views
Message 3 of 4
Flag for a moderator

Re: Poor broadband speed

Also try splitting the wifi signal in the router settings separately, 2.4GHz & 5GHz and connect to the 5GHz channel for the best possible speed, although this still depends on the devices you are connecting and how old they are.

***********************************************************************************************************************************
Super Hub 4.0 (modem mode) - Gig1 Fibre FTTP - Asus RT-AX82U & Asus RT-AX56U with AiMesh setup
***********************************************************************************************************************************
My Broadband Ping - conman33158
0 Kudos
Reply
Emma_C
  • 8.28K
  • 512
  • 559
Forum Team
Forum Team
241 Views
Message 4 of 4
Flag for a moderator

Re: Poor broadband speed

Hi KM84, 

Thanks for your post and welcome to our community. 

Very sorry you're having some issues with the Wi-Fi, this isn't good. 

As well as the above advice which is great, can you also reboot the hub for us please? 

It has been up for a while and some errors are showing. The hub needs to be switched off and left off for at least five minutes to register as being rebooted. 

 

Let us know how you get on. 

Emma_C - Forum Team
0 Kudos
Reply