Showing results for 
Search instead for 
Did you mean: 

Ordering A WiFi Pod

Joining in

I joined VM from Sky 2 days ago because the speed through the phone line was just awful. Signed up to 1Gig & speed is generally vastly better. A huge selling point was the speed guarantee & the offer of pods to improve speed in any blackspots.

However, I'm unable to use Connect app as I have Hub 5 & the app can't connect to the hub to allow me to search for blackspots or order pods. Using a different app, I've identified a couple of blackspots including my home office, where I work 4 days a week.

I need decent speed in the office more than anywhere else in the house.

I've tried using Live Chat to order a pod but it's a virtual agent & I can't get anywhere with it. Could a VM agent please respond to this to help me order a pod for my home office?





Forum Team
Forum Team

Hi @Picapicas 👋 Thank you for your post and welcome to the Virgin Media Community 😀

We're sorry to hear about the problems you've been having 😔

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. 

If this still doesn't help, try clearing the data within the Connect App. 

These steps will help you do that: For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache.

Please let us know how you get on with following that advice. If you're continuing to experience problems, please pop back to us.