cancel
Showing results for 
Search instead for 
Did you mean: 

Not getting full Gig1 speeds

JD2006
Joining in

Switched from BT to Virgin around a week ago for the cheaper and faster download speed, had everything installed by a technician and everything looked fine until I did a speed test and was getting around 700mbps compared to the advertised 1130mbps, found out he installed a cat5 cable so swapped the cable to a cat8 and my speeds jumped to 950mbps which is better but still not the advertised 1130mbps which I definitely want.

I've tried different cables (cat5e and cat8), all get the same speeds. Tried different drivers on my PC, adapter settings, fully reset the hub, tightened coxial cable, updated motherboard BIOS, updated windows; everything I can think of and I still can't get the speeds advertised and yes the ethernet is in the 2.5gbps socket on the router.

My motherboard can pull 2.5Gbps (GIGABYTE X670 AORUS ELITE AX) I'm using a Cat8 ethernet cable directly to the Hub5, the speeds on https://samknows.com/realspeed/ show that my router is pulling 1110 and my device is pulling 1101, but a speed test on Ookla shows 951 and my steam download speed is around 110mb/s, so I don't really know what's going on here if I could even get the 1100~ displayed on the realspeed test I would be happy but if anyone has any ideas that would be great as I would love to get what I'm paying for... 

Thanks!

8 REPLIES 8

carl_pearce
Community elder

If you do a speed test in safe mode with networking what speeds do you get?

Are you using an SSD or conventional hard drive for your steam storage?

Hi, same speeds while booted in safe with networking mode . Ive tried 2 different NVMe M.2 drives, one with 3600/4800mbs read and write speeds and one with 5500/7000mbs.

Martyn
Up to speed

your pc ethernet actually connected at 2.5gb? seems like it might be stuck on 1gb?

Connection: Virgin FTTP Gig2 (XGSPON)

Aaron2
Well-informed

You'll need both a Hub 5 and a computer with a 2.4Gbs ethernet port, if you have the Hub 4 then sadly you'll only be able to get 950Mbs from the Hub via ethernet as the Hub 4 only has 1Gbs ports. If you have the Hub 5 then make sure your Cat8 is connected to port 4 as that's the only 2.5Gb port.


** I work for VirginMedia but all opinions posted here are my own.

Adduxi
Very Insightful Person
Very Insightful Person

Try booting the PC with a live linux distro that has support for the Realtek 2.5Gb NIC on your motherboard.

It could be a driver conflict between the Hub 5 NIC and the Realtek NIC.

A Cat 6a cable is sufficient for your speeds btw, and a Cat 8 may be a hinderance.?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

legacy1
Alessandro Volta

@JD2006 wrote:

Cat8 ethernet cable directly to the Hub5, the speeds on https://samknows.com/realspeed/ show that my router is pulling 1110 and my device is pulling 1101, but a speed test on Ookla shows 951 


Some routes are limited for pulling speed then others

---------------------------------------------------------------

Yes it's connected to 2.5gbps port and my PC can handle that.

I have the Hub5 and my motherboard is capable of 2.5gbps, Cat8 cable is connected to the 2.5gbps port on the router also.