Menu
Reply
M5478
  • 6
  • 0
  • 0
Joining in
573 Views
Message 1 of 16
Flag for a moderator

New to Virgin – slow web browsing issues

Hello,

I had Virgin broadband installed a couple of weeks ago.  Ever since I'm getting very slow speeds and timeouts when browsing websites, to the extent that browsing is almost impossible. 

I would be very grateful for some help it has been a disappointing start with Virgin so far! Here’s a bit more info:

  • All websites seem to be affected, including google.co.uk and virginmedia.com.  Recaptchas often time out
  • Same issue whether connected by Wifi or Ethernet cable
  • Same issue whether using Edge/Chrome/Internet Explorer
  • I’m running a Windows 10 laptop, all available updates have been installed
  • Same issue even if there are no other devices actively using the VM connection
  • Streaming services such as Netflix and BBC iplayer (via smart TVs) are mostly ok, although there can be a bit of a lag when first opened
  • Browsing on an iPhone seems to be ok
  • I signed up for the 50Mbps service.  Speedtests via the Ookla app on my phone come in at around 54Mbps, so it doesn't appear to be a speed issue
  • These browsing issues all started when I switched to VM from Vodafone fibre.  I had no issues with browsing before I switched

Things I have tried to no avail:

  • I have rebooted my laptop
  • I have rebooted my router (Hub 3)
  • Guestnet is switched off on the router
  • I have turned off the advanced error search here (https://my.virginmedia.com/advancederrorsearch/settings )
  • Childsafe is off (Virus safe is on though)
  • No broadband issues have been reported in my area per the VM website or on 0800 561 0061
  • I've checked that all connectors to the VM equipment are hand tight; no damage is visible
  • I’ve set up thinkbroadband's Broadband Quality Monitoring service – have tried to post the link here My BQM 

I'll post my Hub stats in a separate post.

Thanks in advance for your help.

Matt

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
570 Views
Message 2 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

Can you carry out a couple of speed tests at speedtest.net using a direct connection using a Cat 5E/6 cable between the Hub and a 1Gbs capable Pc/Mac/Chromebook and no other devices connected.

Ensure that the Network Interface Card (NIC) drivers are up to date.

Then post the links to the results on here.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
M5478
  • 6
  • 0
  • 0
Joining in
561 Views
Message 3 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

I can't post the Hub stats for some reason - I get an error message saying "Message cannot exceed 20,000 characters."

Here are the speedtest results:

1 (Edge): Speedtest 1 

2. (Chrome): Speedtest 2 

Thanks

0 Kudos
Reply
jhuk
  • 2.99K
  • 52
  • 286
Problem sorter
554 Views
Message 4 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

Since you say slow browsing try another DNS as that is separate from slow downloads if your speed is bad or good.

Google / Cloudfare / OpenDns etc.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
550 Views
Message 5 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

OK, we now know that you can get the contracted speed with Wi-Fi and ethernet connection.

The next thing is to got to your Windows Settings and change the Domain Name Server (DNS).

This >> PAGE << tells you how.

 


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
M5478
  • 6
  • 0
  • 0
Joining in
537 Views
Message 6 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

I’ve changed the DNS to google - unfortunately no improvement.

For example, if I click log in on the NatWest website it takes 70 seconds to fully load the web page (content appears after 30 secs but the circle keeps whirring and the status bar says ‘resolving host’ for the full 70 secs).  That is with using an Ethernet cable and WiFi turned off on the Hub!

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
531 Views
Message 7 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

Please post the link to the website and I will see what I get.

 


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
M5478
  • 6
  • 0
  • 0
Joining in
528 Views
Message 8 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

It’s https://personal.natwest.com - in the top right is the log in button

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
525 Views
Message 9 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

It works perfectly here.

Try another DNS.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
jhuk
  • 2.99K
  • 52
  • 286
Problem sorter
514 Views
Message 10 of 16
Flag for a moderator

Re: New to Virgin – slow web browsing issues

Instant here.

0 Kudos
Reply