Showing results for 
Search instead for 
Did you mean: 

New 350mbps So Slow

On our wavelength

Hi I'm new on here, hope someone can help, I had a 200mbps broadband package for nearly 3 years and the speeds were brilliant, over a week ago I upgraded to 350mbps package, the speeds are so slow and sometimes I loose connection, two engineers came out and could not find anything wrong, my Ethernet download speed was 172mbps on SamKnows  the in coming from Virgin was 385mbps. Then 185mbps on Speednet by Ookla, my Wi-Fi is around 134mbps. This photo below shows the speed when I was on the 200mbps package Wi-Fi results.


This picture below shows the speeds on the 350mbps


My set up is just the same as it was before the upgrade nothing changed, the engineers said I cannot expect fast speeds, I told them that I got fast speeds when I was on the 200mbps as in the first photo, how come it's slower now, I don't know was the reply.


Very Insightful Person
Very Insightful Person
First thing is to reset the Hub this way...
Note that a pinhole reset on a Hub3/4/5 can be a bit problematic - so do it (again) EXACTLY this way (not as the VM website says!).

Firstly, make sure the Hub's sticker/card with the two passwords on it is still there and legible If not – DON’T DO IT !

With the Hub switched "on", disconnect any ethernet connections (leave the co-ax connected) and then push in the “reset pin” with the end of a paperclip/thin nail/SIM tray “tool” or similar (bigger items like ball point pen ends may not press it in far enough) until you feel it at the “stop point” and hold it there firmly for a "timed" minimum of 60 seconds do NOT manually restart the Hub at any time. Leave it 10' or so to stabilise and then your passwords/passphrase for both the Hub settings and the Wifi networks will revert to the two printed on the Hub sticker on its base/side/card. The SSID’s will revert to that on the sticker too. Make sure you use the wifi one for devices connecting to the wifi and the settings/admin one to access the Hub.
You will need to reconnect your devices if you had changed the password, or just change the password back to your preferred one.

See if that sorts it.


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 1 WiFi, 1 on PA) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's. On 250Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Tried this but it didn't fix the issue.

Very Insightful Person
Very Insightful Person
Can you try a "pure" speedtest as below - this will report the speeds that are coming to the Hub

Connect a 1GB enabled computer/laptop, with up to date drivers, via a NEW and working Cat5e/6a ethernet cable, directly to the Hub which you have put into “modem mode” ( ). This ensures that NO other devices are connected

Test speeds at - try on 2 different browsers.

If they are still low – boot your device into Windows safe+networking mode - to disable any potentially interfering software - and try again.

There are many posts on here (I have a list of ~30!) where QoS software, unknown/flaky software, old network card drivers, corrupted browsers, bad cables or other connected devices are limiting speeds on tests.

Report back what that gets. A couple of examples why... See message 9 in the first thread and… 3 in the second


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 1 WiFi, 1 on PA) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's. On 250Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Hi Applescruff, 

Thanks for your post and welcome to the forums. It's great having you on board with us in the Community. 

I'm sorry to hear you're getting slower speeds since upgrading. 

Checking our systems, I can see all is looking well with the Hub in terms of power levels, uptime and time outs. There are no faults open that may be affecting you either. 

Can you please do the speed test as per the instructions from jbrennand and let us know how it goes. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

The engineers tested with their meter, on Saturday the speed went up to over 300mbps but soon went back down see attached results.



Forgot to add, I had a message from Virgin telling me that work is being carried out in my area tomorrow 27th July maybe this will correct what is ever going on, fingers crossed, down to 60mbps and below at the moment.

Work completed still extremely slow speed, going to contact Virgin and end my new contract. The thing is that know that I am in a wheelchair and that I rely on my broadband and Wi-Fi for everything shopping, contact, ordering meds, contacting my medical support team, bills etc, etc,. I'm fed up watching streaming and the message connection problem when the streaming device is connected to the ethernet, and yes I have tried different cables.

Hi Applescruff,

Thank you for reaching back out, sorry to hear you are still not getting your expected speeds, I was able to locate you on our system with the detail's we have for you and cannot see any issues other than possible WIFI issues, you said the device you are stream from is connected Via an ethernet cable , what device is it, are you using a Cat 6 or above ethernet cable, what speed to you get to the Router when you do a speed test Via Sam Know Real Speed?




My pc is connected to Ethernet cat6 cable, Samknows reads virgin 384mbps my download 172mbps Ethernet to pc.