Menu
Reply
bradyar
  • 3
  • 0
  • 0
Joining in
435 Views
Message 1 of 7
Flag for a moderator

M500 package but getting 60 download and 2 upload

Hey there, I have recently upgraded to the M500 package but I have seen no improvements in my broadband speeds. I am connected through an ethernet powerline using cat7 cables. With the M500 package, I expected to see at least 280+ download speed as well as 35+ upload but I am seeing nowhere near these results. I am getting 60 download speed and 2 upload speed. Any help would be greatly appreciated.

Thanks a lot

Tags (1)
0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
420 Views
Message 2 of 7
Flag for a moderator

Re: M500 package but getting 60 download and 2 upload

Can you check the Network Interface Card in your PC, ensure it is set to 100/1000 and the drivers are up to date.

Also can you speed test with a 1 Gig enabled device connected directly to the Hub with the best ethernet cable that you have.

Powerlines can be brilliant in some cases and absolutely awful in many others.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
bradyar
  • 3
  • 0
  • 0
Joining in
414 Views
Message 3 of 7
Flag for a moderator

Re: M500 package but getting 60 download and 2 upload

I have checked my Network Interface Card and it is set to the correct speed and all my drivers are up to date. I am unable to connect straight to the router and I have the fastest powerline adapter possible.

Thanks for your help

0 Kudos
Reply
Adduxi
  • 2.87K
  • 214
  • 610
Trouble shooter
406 Views
Message 4 of 7
Flag for a moderator

Re: M500 package but getting 60 download and 2 upload


@bradyar wrote:

I have checked my Network Interface Card and it is set to the correct speed and all my drivers are up to date. I am unable to connect straight to the router and I have the fastest powerline adapter possible.

Thanks for your help


Unless you test directly cabled to the Hub, you can't do speed tests. VM will insist on direct connected tests.

Also powerline adapters will not give full speed as it all depends on the electrical wiring.

0 Kudos
Reply
bradyar
  • 3
  • 0
  • 0
Joining in
399 Views
Message 5 of 7
Flag for a moderator

Re: M500 package but getting 60 download and 2 upload

Found a laptop which was compatible and I connected it straight to the router and I was getting 390+ download and 36+ upload. It was quite an outdated laptop as well.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
324 Views
Message 6 of 7
Flag for a moderator

Re: M500 package but getting 60 download and 2 upload

Using the same laptop check your speed at the Hub then go straight to the other end of the PLA and test again.

Post both sets of results.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
Anonymous
Not applicable
291 Views
Message 7 of 7
Flag for a moderator

Re: M500 package but getting 60 download and 2 upload

It would be worth mentioning which power line adapter you have.

Some quote speeds that they are not capable of, for example they say they use gigabit ethernet adpaters when the technology they use is not gigabit!

0 Kudos
Reply