• 1
  • 0
  • 0
Joining in
Message 1 of 2
Flag for a moderator

M350 getting 92mbps


I have had successfully used Virgin 200 for a while no problems occasional restarts of router needed.

I upgraded to 350 which was this speed for a few weeks and for the past 30 days I have only receive 92mbps. this is wired speed test through my plume wifi device.  

All was ok but not now. I have gone through the steps virgin outline - check cables and reboot router etc a couple of times but no joy. Any ideas? I tried calling but the auto assistant just says restart router and good bye.

0 Kudos
  • 5.95K
  • 665
  • 2.05K
Very Insightful Person
Very Insightful Person
Message 2 of 2
Flag for a moderator

Re: M350 getting 92mbps

For a wired connection, speeds below 100Mbps per second as you describe are often the result of the device not being able to negotiate a gigabit connection with the hub.  This can be the result of faulty drivers on your PC, or a damaged Ethernet cable.  Always worth trying a different cable and if possible a different device.

Have you tried connecting direct to the hub to rule out the Plume device as the bottleneck?  It will be one of the first thing VM staff will ask you to do as they can only support VM kit.


My setup: VM TV box, M350 Fibre broadband with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks