Menu
Reply
supra3turbo
  • 7
  • 0
  • 0
Tuning in
331 Views
Message 1 of 3
Flag for a moderator

M350 Broadband

Hi There,

The guy came yesterday to do my broadband, i showed him the box's outside and 2 had been snipped out and mine was linked into 1 box, he put a splitter on the input and connected me.

I am getting 50-80mbps on speedtest, he said this is because of work going on in the area, im just wondering, would i need him to connect me to a M350 line? If the line coming in is only for M100 would this cause my speed issues?

He did say that everything would be fine by the 23rd, but i find it odd that speedtest is showing it that low, indicating that the line coming into the house is slow?

I am paying for the M350 package, and its going to be almost a month before i will get my fast speeds you see, what would you reccomend i do?

 

Thanks - Joe

Tags (3)
0 Kudos
Reply
Cutters1982
  • 24
  • 0
  • 0
Tuning in
297 Views
Message 2 of 3
Flag for a moderator

Re: M350 Broadband

I'd make a complaint if it were me, you're not getting anything like the advertised speed, and by the sounds of it, for almost a month, your bill should be altered accordingly if that's how it's going to be, I wouldn't put up with it myself 😞
0 Kudos
Reply
supra3turbo
  • 7
  • 0
  • 0
Tuning in
294 Views
Message 3 of 3
Flag for a moderator

Re: M350 Broadband

Im on the phone now to virgin, as soon as i called it said "we are sorry you are experiencing problems in the oldham area, all our technitions are working hard to fix this problem" so there must be a problem.... Ill try and have them ammend my bill for me, i dont want to pay full price for a quarter of the speed.

Thanks - Joe
0 Kudos
Reply