Menu
Reply
Ciaronsmethurst
  • 1
  • 0
  • 0
Just joined
222 Views
Message 1 of 2
Flag for a moderator

Hub 4 Slow Speeds

I'm usually not one to complain about Virgin.. for the past 3 years my internet has been perfect. I recently upgraded from 350 MB to Gig1 Fibre and a new hub 4 was offered, and of course I took it. 

I plugged in the hub, did the activation sms and waited a whole 24 hours, ran a speed test after noticing problems downloading games on my Xbox One X and the speed test was showing a 50mbps speed. 

I waited a further 24 hours and no changes, I went through every troubleshooting I read online including restarting, completelt unplugging,  changing ethernets etc. Etc. Still no luck.

I do another speed test today and its dropped from a 50 mbps average to 2 mbps average.. 

Is my Hub4 Faulty?

Has my internet actually been activated? 

What else do I need to do?

Thanks

Ciaron

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
137 Views
Message 2 of 2
Flag for a moderator

Re: Hub 4 Slow Speeds

What speeds do you get at >> Sam Knows Real Speed << with a direct connection using a Cat 5E or better ethernet cable between the Hub in Router Mode and a 1Gbs capable Pc/Mac/Chromebook and no other devices connected ?

Then immediately after …

Can you Login to the Hub Settings and navigate to the Connected Devices page - what is the reported 'connection speed’ for the ethernet cable connected device you used for the speed test ?


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply