Menu
Reply
KARSAQ
  • 4
  • 0
  • 0
Tuning in
542 Views
Message 1 of 8
Flag for a moderator

Horrible Service by Virgin Media

just moved to UK and applied for 1GB broadband, once I install and check the speed its only 500MB. If you think no matter what then why the hell Virgin signed a deal for 1GB?  but question is, how the hell reach to any customer service representative where I can ask my questions?  there is NO Way I can reach out to any at Virgin. Either its a paid phone which rings for 26 min but no one answers or only online available content. 

can you pls suggest how I can reach out to Virgin with my question?  any email, or anything?  

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.95K
Alessandro Volta
537 Views
Message 2 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

What speeds do you get at >> Sam Knows Real Speed << with a direct connection using a Cat 5E or better ethernet cable between the Hub in Router Mode and a 1Gbs capable Pc/Mac/Chromebook and no other devices connected ?


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
KARSAQ
  • 4
  • 0
  • 0
Tuning in
522 Views
Message 3 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

I have not connected with ethernet but speed check via WIFI, its download: 507 and Upload 27.7.  
we will connect TV next week but as of today only 3 laptops using wifi. (thanks for help)

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.95K
Alessandro Volta
516 Views
Message 4 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

Are those speeds from Sam Knows Real Speed ?

Wi-Fi speeds are not accepted as low speed evidence by VM because there are far too many things that can affet Wi-Fi broadcasts.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
BoneMatrix
  • 56
  • 0
  • 4
Dialled in
515 Views
Message 5 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

You are never going to get 1Gbps with WiFi

Always test speed via a Cat5e or better cable!

However, yes, the current VM broadband speeds are woeful, even with a cable (we're in Area 20 and despite their recent price hike, we're only getting 15-20mbps down and 0.5mbps up at best for their 100 down/10 up mbps). 😡

Needless to say, we're looking elsewhere for an ISP!

KARSAQ
  • 4
  • 0
  • 0
Tuning in
387 Views
Message 6 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

Yes, checked, and its showing the same speed. even below 500mb

0 Kudos
Reply
KARSAQ
  • 4
  • 0
  • 0
Tuning in
386 Views
Message 7 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

does anyone get any idea, how to reach out to VM ? there is a phone number and I call twice, 9 min and then 32 min, no one picks up, just keep getting msg, the agent will with you soon and its a paid line. 

0 Kudos
Reply
RedGooner
  • 1.93K
  • 69
  • 259
Super solver
356 Views
Message 8 of 8
Flag for a moderator

Re: Horrible Service by Virgin Media

How are you doing the testing ??

As said by other posters, always use a Wired connection.

Please post some screen shoots of your test speeds. Its not hard to cut and paste a picture.

If your on Win10 download the Speedtest app by Ookla. I find this better than the webpage version.

This is an example (my connection speed).

VM14012021.JPG

 

 

 

--
Red (VM SH2 AC Beta tester)
Running on 1Gbps VM service with SH4 in Modem Mode, with a ASUS RT-AC5300 router. With this setup I get Fantastic WIRED and WIRELESS Signals in my home. I dont work for VM. But I work in IT, and I know my tech.
My advice is at your own risk. If you are happy with my answers please press Kudo ?
0 Kudos
Reply